XXHighEnd - The Ultra HighEnd Audio Player
October 25, 2014, 12:12:06 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Dec. 31, 2012 : XXHighEnd + Phasure NOS1 DAC receive 6moons Blue Moon Award !
** "Lonely at the very top" **
Search current board structure only !!  
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: Bug in playlist 0.9z6.1c?  (Read 1948 times)
0 Members and 1 Guest are viewing this topic.
digitalman
Audio Loudspeaker
*
Offline Offline

Posts: 24


View Profile
« on: July 29, 2012, 01:42:43 am »

Hi Peter,

After a long time i decided to try out xxhighend again with the latest version 0.9z6.1c on my laptop. Everything is working fine exept i have a stange problem by loading different tracks with the same filename in the playlist and play them.

For example i have two diffenent albums with tracks called:

Album1
-Track1
-Track2
-Track3
Album2
-Track1
-Track2
-Track3
-Track4

I put them in the play list and start to play the first 2 tracks of album 1. Everything went okay and music is playing. Then i stop playback And make a new selection of  track1&track2 from album 2. Then hit play but to my suprise i don't hear track 1 from Album 2 but track 1 from Album 1.

I have tested it with different tracks with the same tracknames. But with every try i had the same problem. It looks like xxhighend didn't check if the newly selected track1 is different than the one played before and assumes that is not a new selected track but the old one and so starts to play the old (already in memory) track1.

So it looks to me that xxhighend only checks on the name of the file (track) and not on it's properties like size, location or crc code etc. to determine if it's a different track (file) or not. But maybe i'm totally wrong by this...


Hope i explained the problem clearly to you with the above example and that you can reproduce the problem (bug?).

Greetings,
Martijn

 
Logged

Notebook Core2Duo 2,1GHz, 2GB, Windows 7 Ultimate 32bit SP1, xxhe 09-z3, Engine#4 Adaptive Mode / Q1/2/3/4/5 = 1/0/0/0/0 (Dev.Buffer = 2048, Invert / Playerprio = Nothing / ThreadPrio = Real Time / Unattended /Services Off / Double 96/32 Upsampling / PC -> Hiface -> Lampizator Dac gen. 2.5, Level 3 -> Astin Trew AT1000/AT5000 -> Jean Marie Reynaud Opus 2
PeterSt
Administrator
High Grade Audiophile
*****
Offline Offline

Posts: 11019



View Profile
« Reply #1 on: July 29, 2012, 08:38:04 am »

Hey Martiijn,

It is not really intended, but it is so, yes. It depends a bit in what format the the source is, and IIRC if these were FLACs it goess all right (or just not and WAC is all right). Anyway :

Would you be explicitly testing things (like two normal track names from different locations) you must explicitly clear the "caches" by using that little button close to the bottom under the Load button (the rightmost one).
When you just play such a playlist from top to bottom this doesn't work of course. Then you'd have to stop after Album 1, use that button and continue with Album 2.

Regards,
Peter
Logged

** Denote the latest changes.

W7 - February 9, 2014 (1.186-a)
XXHighEnd PC -> i7 3930K Hyperthreading On (12 cores) @*500MHz*, 16GB, Windows 7 Enterprise 64bit on EMedia SATAIII 2.5" 7200RMP spinning disk, XXHE on 2GB RAMDisk (IMDisk), music on LAN (dynamically stopped/started) / Engine#4 Adaptive Mode / Q1/-/3/4/5 = *6*/-/1/1/1 / Q1Factor = *1* / Dev.Buffer = 4096 / ClockRes = 15ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = *0.40* (max 320.00) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = *Core3-5* / Not Switch Processors during Playback / Playback Drive 2GB RAMDisk (IMDisk) / UnAttended (Just Start) / All Services Off / Keep LAN - *Persist* (this is for conveniency and sub 1.186a)  / No WallPaper / No OSD / No Running Time / Minimize OS / XTweaks : *Use Settings* - *64, 1, 1, 0, 1* / Time Performance Index = Optimal / Time Stability = On / Double Octo Arc Prediction Upsampling / -> USB3 (*Silverstone *both* sides isolated*) -> 24/768 Phasure NOS1 async USB DAC, Driver v1.0.3 (*16ms*) -> Orelo MKII Active Open Baffle Horn Speakers.
**Removed Switching Supplies from everywhere**

W8 - March 1, 2014 (1.186-a)
XXHighEnd PC -> i7 3930K Hyperthreading On (12 cores) @0.43GHz, 16GB, Windows 8 Pro 64bit on EMedia SATAIII 2.5" 7200RMP spinning disk, XXHE on 2GB RAMDisk (IMDisk), music on LAN (dynamically stopped/started) / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 6/-/1/1/1 / Q1Factor = 1 / Dev.Buffer = 4096 / ClockRes = *0.5ms* / Memory = Straight Contiguous / Include Garbage Collect / SFS = *0.32* (max 120) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = *Core3-5* / Not Switch Processors during Playback / Playback Drive 2GB RAMDisk (IMDisk) / UnAttended (Just Start) / All Services Off / Keep LAN - Not Persist / No WallPaper / No OSD / No Running Time / Minimize OS / XTweaks : Balanced Load = 43 / Nervous Rate = *1* / Cool when Idle = 1 / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = Optimal / Time Stability = On / Double Octo Arc Prediction Upsampling / -> USB3 (Silverstone both sides isolated) -> 24/768 *modded* Phasure NOS1 async USB DAC, Driver v1.0.3 (2ms - this is not guaranteed for the NOS1) -> Orelo MKII Active Open Baffle Horn Speakers.
Removed Switching Supplies from everywhere

Global Moderator
digitalman
Audio Loudspeaker
*
Offline Offline

Posts: 24


View Profile
« Reply #2 on: July 31, 2012, 01:09:11 pm »

Hey Peter,

If it's intended to function that way it's no problem for me. I thought maybe it was a bug and you would be interested to know. I had only the problem when i put two albums in the playlist which are not converted with track names because of leg of cddb information. The change of happening is small but i had it by hand so i thought i report it.

Cheers with your new version of xxhe. I hope to have the pleasure to try it very soon!

Regards,
Martijn
Logged

Notebook Core2Duo 2,1GHz, 2GB, Windows 7 Ultimate 32bit SP1, xxhe 09-z3, Engine#4 Adaptive Mode / Q1/2/3/4/5 = 1/0/0/0/0 (Dev.Buffer = 2048, Invert / Playerprio = Nothing / ThreadPrio = Real Time / Unattended /Services Off / Double 96/32 Upsampling / PC -> Hiface -> Lampizator Dac gen. 2.5, Level 3 -> Astin Trew AT1000/AT5000 -> Jean Marie Reynaud Opus 2
digitalman
Audio Loudspeaker
*
Offline Offline

Posts: 24


View Profile
« Reply #3 on: July 31, 2012, 01:25:16 pm »

I read you previous post more carefully again and saw that this behavior was not intended that way, but already known by you. So if it's no problem for you, i have no problem with it either!

Regards,
Martijn
Logged

Notebook Core2Duo 2,1GHz, 2GB, Windows 7 Ultimate 32bit SP1, xxhe 09-z3, Engine#4 Adaptive Mode / Q1/2/3/4/5 = 1/0/0/0/0 (Dev.Buffer = 2048, Invert / Playerprio = Nothing / ThreadPrio = Real Time / Unattended /Services Off / Double 96/32 Upsampling / PC -> Hiface -> Lampizator Dac gen. 2.5, Level 3 -> Astin Trew AT1000/AT5000 -> Jean Marie Reynaud Opus 2
PeterSt
Administrator
High Grade Audiophile
*****
Offline Offline

Posts: 11019



View Profile
« Reply #4 on: July 31, 2012, 01:49:30 pm »

Nah, I meant with "not intended" that obviously this is not much convenient, although the chance is normally small or inexistent that it happens. But it just is so and a tough thing to solve (because it is about caches and they work upon the unique name (which names are not unique in your example)).

Regards,
Peter
Logged

** Denote the latest changes.

W7 - February 9, 2014 (1.186-a)
XXHighEnd PC -> i7 3930K Hyperthreading On (12 cores) @*500MHz*, 16GB, Windows 7 Enterprise 64bit on EMedia SATAIII 2.5" 7200RMP spinning disk, XXHE on 2GB RAMDisk (IMDisk), music on LAN (dynamically stopped/started) / Engine#4 Adaptive Mode / Q1/-/3/4/5 = *6*/-/1/1/1 / Q1Factor = *1* / Dev.Buffer = 4096 / ClockRes = 15ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = *0.40* (max 320.00) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = *Core3-5* / Not Switch Processors during Playback / Playback Drive 2GB RAMDisk (IMDisk) / UnAttended (Just Start) / All Services Off / Keep LAN - *Persist* (this is for conveniency and sub 1.186a)  / No WallPaper / No OSD / No Running Time / Minimize OS / XTweaks : *Use Settings* - *64, 1, 1, 0, 1* / Time Performance Index = Optimal / Time Stability = On / Double Octo Arc Prediction Upsampling / -> USB3 (*Silverstone *both* sides isolated*) -> 24/768 Phasure NOS1 async USB DAC, Driver v1.0.3 (*16ms*) -> Orelo MKII Active Open Baffle Horn Speakers.
**Removed Switching Supplies from everywhere**

W8 - March 1, 2014 (1.186-a)
XXHighEnd PC -> i7 3930K Hyperthreading On (12 cores) @0.43GHz, 16GB, Windows 8 Pro 64bit on EMedia SATAIII 2.5" 7200RMP spinning disk, XXHE on 2GB RAMDisk (IMDisk), music on LAN (dynamically stopped/started) / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 6/-/1/1/1 / Q1Factor = 1 / Dev.Buffer = 4096 / ClockRes = *0.5ms* / Memory = Straight Contiguous / Include Garbage Collect / SFS = *0.32* (max 120) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = *Core3-5* / Not Switch Processors during Playback / Playback Drive 2GB RAMDisk (IMDisk) / UnAttended (Just Start) / All Services Off / Keep LAN - Not Persist / No WallPaper / No OSD / No Running Time / Minimize OS / XTweaks : Balanced Load = 43 / Nervous Rate = *1* / Cool when Idle = 1 / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = Optimal / Time Stability = On / Double Octo Arc Prediction Upsampling / -> USB3 (Silverstone both sides isolated) -> 24/768 *modded* Phasure NOS1 async USB DAC, Driver v1.0.3 (2ms - this is not guaranteed for the NOS1) -> Orelo MKII Active Open Baffle Horn Speakers.
Removed Switching Supplies from everywhere

Global Moderator
digitalman
Audio Loudspeaker
*
Offline Offline

Posts: 24


View Profile
« Reply #5 on: August 02, 2012, 01:31:42 am »

Okay, but why is Album 1\Titel 1 en Album 2\Titel 1 not unique? There is a clear difference in the path name Album 1 and Album 2 or not?

Regards,
Martijn
Logged

Notebook Core2Duo 2,1GHz, 2GB, Windows 7 Ultimate 32bit SP1, xxhe 09-z3, Engine#4 Adaptive Mode / Q1/2/3/4/5 = 1/0/0/0/0 (Dev.Buffer = 2048, Invert / Playerprio = Nothing / ThreadPrio = Real Time / Unattended /Services Off / Double 96/32 Upsampling / PC -> Hiface -> Lampizator Dac gen. 2.5, Level 3 -> Astin Trew AT1000/AT5000 -> Jean Marie Reynaud Opus 2
PeterSt
Administrator
High Grade Audiophile
*****
Offline Offline

Posts: 11019



View Profile
« Reply #6 on: August 02, 2012, 07:04:07 am »

Hi Martijn - This is because the album part isn't involved here. Image the track to be copied to that "cache" location. I don't say it couldn't have been made differently, but this is how it works.

Regards,
Peter
Logged

** Denote the latest changes.

W7 - February 9, 2014 (1.186-a)
XXHighEnd PC -> i7 3930K Hyperthreading On (12 cores) @*500MHz*, 16GB, Windows 7 Enterprise 64bit on EMedia SATAIII 2.5" 7200RMP spinning disk, XXHE on 2GB RAMDisk (IMDisk), music on LAN (dynamically stopped/started) / Engine#4 Adaptive Mode / Q1/-/3/4/5 = *6*/-/1/1/1 / Q1Factor = *1* / Dev.Buffer = 4096 / ClockRes = 15ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = *0.40* (max 320.00) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = *Core3-5* / Not Switch Processors during Playback / Playback Drive 2GB RAMDisk (IMDisk) / UnAttended (Just Start) / All Services Off / Keep LAN - *Persist* (this is for conveniency and sub 1.186a)  / No WallPaper / No OSD / No Running Time / Minimize OS / XTweaks : *Use Settings* - *64, 1, 1, 0, 1* / Time Performance Index = Optimal / Time Stability = On / Double Octo Arc Prediction Upsampling / -> USB3 (*Silverstone *both* sides isolated*) -> 24/768 Phasure NOS1 async USB DAC, Driver v1.0.3 (*16ms*) -> Orelo MKII Active Open Baffle Horn Speakers.
**Removed Switching Supplies from everywhere**

W8 - March 1, 2014 (1.186-a)
XXHighEnd PC -> i7 3930K Hyperthreading On (12 cores) @0.43GHz, 16GB, Windows 8 Pro 64bit on EMedia SATAIII 2.5" 7200RMP spinning disk, XXHE on 2GB RAMDisk (IMDisk), music on LAN (dynamically stopped/started) / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 6/-/1/1/1 / Q1Factor = 1 / Dev.Buffer = 4096 / ClockRes = *0.5ms* / Memory = Straight Contiguous / Include Garbage Collect / SFS = *0.32* (max 120) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = *Core3-5* / Not Switch Processors during Playback / Playback Drive 2GB RAMDisk (IMDisk) / UnAttended (Just Start) / All Services Off / Keep LAN - Not Persist / No WallPaper / No OSD / No Running Time / Minimize OS / XTweaks : Balanced Load = 43 / Nervous Rate = *1* / Cool when Idle = 1 / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = Optimal / Time Stability = On / Double Octo Arc Prediction Upsampling / -> USB3 (Silverstone both sides isolated) -> 24/768 *modded* Phasure NOS1 async USB DAC, Driver v1.0.3 (2ms - this is not guaranteed for the NOS1) -> Orelo MKII Active Open Baffle Horn Speakers.
Removed Switching Supplies from everywhere

Global Moderator
digitalman
Audio Loudspeaker
*
Offline Offline

Posts: 24


View Profile
« Reply #7 on: August 03, 2012, 11:27:28 pm »

Hi Peter,

thanks for you explanation!

Regards,
Martijn
Logged

Notebook Core2Duo 2,1GHz, 2GB, Windows 7 Ultimate 32bit SP1, xxhe 09-z3, Engine#4 Adaptive Mode / Q1/2/3/4/5 = 1/0/0/0/0 (Dev.Buffer = 2048, Invert / Playerprio = Nothing / ThreadPrio = Real Time / Unattended /Services Off / Double 96/32 Upsampling / PC -> Hiface -> Lampizator Dac gen. 2.5, Level 3 -> Astin Trew AT1000/AT5000 -> Jean Marie Reynaud Opus 2
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1 RC2 | SMF © 2001-2005, Lewis Media Valid XHTML 1.0! Valid CSS!
Page created in 0.291 seconds with 20 queries.