XXHighEnd - The Ultra HighEnd Audio Player
December 09, 2019, 10:57:59 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: August 6, 2017 : Phasure Webshop open ! Go to the Shop
Search current board structure only !!  
   Home   Help Search Login Register  
Pages: 1 2 3 4 [5]  All
  Print  
Author Topic: No coverart with NAS  (Read 50203 times)
0 Members and 0 Guests are viewing this topic.
arvind
Audio Enthusiast
**
Offline Offline

Posts: 490


View Profile
« Reply #60 on: March 17, 2018, 05:08:29 pm »

Hi Peter,

Accessing the Cover art image folder from the Audio PC is not possible, a window pops up “Class not registered”. This happens in normal OS as well as Min OS.

All my rips are using dBPoweramp & the cover art image is obtained through their database.

Best regards,

Arvind
Logged

W10-14393.0 RAM OS / Mach III LPS 14/28/XXHE 2.10c/Engine#4/Adaptive Mode/16x /Custom Filter/Q1= 30/1/1/1/xQ1=5/Device Buffer:4096/Invert Phase=On/Minimise OS/PE=off/Unattended/Stop All Services/SFS=0.69/140.19(max)/ClockRes= 15ms/Straight Contiguous/Music on NAS/Lush^2 USB cable A:B-W-Y-R; B: B-W-R/Phasure NOS 1a/75b/G3 USB DAC. Blaxius^2 A: B-R; B: B-R. Orelo MK II active speakers. Driver version 1.04/Driver Buffer 16ms. OSD text = Off
PeterSt
Administrator
High Grade Audiophile
*****
Offline Offline

Posts: 15547



View Profile Email
« Reply #61 on: March 17, 2018, 06:00:58 pm »


Hi Arvind,

Quote
All my rips are using dBPoweramp & the cover art image is obtained through their database.

Ehh ... you mean when you start Explorer on the Audio PCm go to the folder where the image files reside and then "they are / have to be accessed through the DBPoweramp database ?
No. That can't be right. And if it is correct then obviously XXHighEnd can't reach for the files. Envision that XXHighEnd would do the same as you do (grab the file via Explorer).

Please keep in mind : the Coverart images reside in the same folder as the music files for an album, or perhaps in a sub folder of that. Not in any different place (like JRiver could do that, but for obvious reasons no random program not knowing about that can "find" them as such). Btw, if I start to be correct about this and thus "knowing" that this never can work like this, how is it related to FLAC ?

So what am I missing ?
(or you Happy)

Peter
Logged

For the Stealth III LPS PC :
W10-14393.0 - Oct 31, 2018 (2.10)
XXHighEnd Mach III Stealth LPS PC -> Xeon Scalable 14/28 core with Hyperthreading On (set to 10/20 cores) @~660MHz, 48GB, Windows 10 Pro 64 bit build 14393.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 30/-/1/1/1/ Q1Factor = 10 / Dev.Buffer = 4096 / ClockRes = 15ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = 140.19  (max 140.19) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / Stop Desktop, Remaining, WASAPI and W10 services / Use Remote Desktop / Keep LAN - Not Persist / WallPaper On / OSD Off (!) / Running Time Off / Minimize OS / XTweaks : Balanced Load = 35 / Nervous Rate = 10 / Cool when Idle = n.a / Provide Stable Power = 0 / Utilize Cores always = 1 / Time Performance Index = Optimal / Time Stability = Stable / *Arc Prediction Filtering (16x)* / Always Clear Proxy before Playback = On -> USB3 from MoBo -> Lush^2*A:B-W-Y-R, B:B-W-R* USB 1m00 -> Phisolator 24/768 Phasure NOS1a/G3 75B (BNC Out) async USB DAC, Driver v1.0.4b (16ms) -> B'ASS Current Amplifier -> *Blaxius^2 A:B-R, B:B-R* Interlink -> Orelo MKII Active Open Baffle Horn Speakers.
Removed Switching Supplies from everywhere (also from the PC).

For a general PC :
W10-10586.0 - May 2016 (2.05+)
*XXHighEnd PC -> I7 3930k with Hyperthreading On (12 cores)* @~500MHz, 16GB, Windows 10 Pro 64 bit build 10586.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/1/1/1 / Q1Factor = 1 / Dev.Buffer = 4096 / ClockRes = 1ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = 0.10  (max 60) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / All Services Off / Keep LAN - Not Persist / WallPaper On / OSD On / Running Time Off / Minimize OS / XTweaks : Balanced Load = *43* / Nervous Rate = 1 / Cool when Idle = 1 / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = *Optimal* / Time Stability = *Stable* / Custom Filter *Low* 705600 / -> USB3 *from MoBo* -> Clairixa USB 15cm -> Intona Isolator -> Clairixa USB 1m80 -> 24/768 Phasure NOS1a 75B (BNC Out) async USB DAC, Driver v1.0.4b (4ms) -> Blaxius BNC interlink *-> B'ASS Current Amplifier /w Level4 -> Blaxius Interlink* -> Orelo MKII Active Open Baffle Horn Speakers.
Removed Switching Supplies from everywhere.

Global Moderator
arvind
Audio Enthusiast
**
Offline Offline

Posts: 490


View Profile
« Reply #62 on: March 18, 2018, 07:45:07 am »

Hi Peter,

It seems the problem of no cover art while playback, at least in my case, was due to corrupt image files in a few of the FLAC music folders. I deleted the image files & downloaded new ones & now it’s working fine.

However starting Explorer from the Audio PC & trying to open the image files WAV or FLAC, does not open the files. From the the music server pc the image files open.

Best regards,

Arvind
Logged

W10-14393.0 RAM OS / Mach III LPS 14/28/XXHE 2.10c/Engine#4/Adaptive Mode/16x /Custom Filter/Q1= 30/1/1/1/xQ1=5/Device Buffer:4096/Invert Phase=On/Minimise OS/PE=off/Unattended/Stop All Services/SFS=0.69/140.19(max)/ClockRes= 15ms/Straight Contiguous/Music on NAS/Lush^2 USB cable A:B-W-Y-R; B: B-W-R/Phasure NOS 1a/75b/G3 USB DAC. Blaxius^2 A: B-R; B: B-R. Orelo MK II active speakers. Driver version 1.04/Driver Buffer 16ms. OSD text = Off
PeterSt
Administrator
High Grade Audiophile
*****
Offline Offline

Posts: 15547



View Profile Email
« Reply #63 on: March 18, 2018, 08:22:54 am »

Hello Arvind,

Quote
It seems the problem of no cover art while playback, at least in my case, was due to corrupt image files in a few of the FLAC music folders. I deleted the image files & downloaded new ones & now it’s working fine.

Maybe. But maybe it has been a sort of rights problem. So ever back the files got there by "a" means (copied from somewhere via some means and then especially thinking about the PC (or Mac) doing it) and now you do this again in your own environment and all is fine.

Quote
However starting Explorer from the Audio PC & trying to open the image files WAV or FLAC, does not open the files.

So this is a completely different issue and btw again not FLAC related. But also no problem. So in case I got you worried, my examples about Explorer were only virtual so you could understand what internally kind of happens and how you can mimic this yourself. This though, is to some degree as we now see as working really via Explorer is more formal than what happens in a program (or how the program can be manipulative regarding this).
So no problem and don't attempt to view the images on your Audio PC. AND :
Be careful, because thinking about this, you probably won't be able to view any picture on the Audio PC by normal Windows means. This is how IrfanView ended up in the XXHighEnd folder since 209 or 2.08 (but recently). This is all related to MinOS and what 14393.0 can still do (or not do).

Anyway, problem solved. For Richard too I assume, since he doesn't seem to be compelled much to (re)join the discussion Happy Haha.

Thank you very much for your help, Arvind. And it helped yourself !
Peter
Logged

For the Stealth III LPS PC :
W10-14393.0 - Oct 31, 2018 (2.10)
XXHighEnd Mach III Stealth LPS PC -> Xeon Scalable 14/28 core with Hyperthreading On (set to 10/20 cores) @~660MHz, 48GB, Windows 10 Pro 64 bit build 14393.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 30/-/1/1/1/ Q1Factor = 10 / Dev.Buffer = 4096 / ClockRes = 15ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = 140.19  (max 140.19) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / Stop Desktop, Remaining, WASAPI and W10 services / Use Remote Desktop / Keep LAN - Not Persist / WallPaper On / OSD Off (!) / Running Time Off / Minimize OS / XTweaks : Balanced Load = 35 / Nervous Rate = 10 / Cool when Idle = n.a / Provide Stable Power = 0 / Utilize Cores always = 1 / Time Performance Index = Optimal / Time Stability = Stable / *Arc Prediction Filtering (16x)* / Always Clear Proxy before Playback = On -> USB3 from MoBo -> Lush^2*A:B-W-Y-R, B:B-W-R* USB 1m00 -> Phisolator 24/768 Phasure NOS1a/G3 75B (BNC Out) async USB DAC, Driver v1.0.4b (16ms) -> B'ASS Current Amplifier -> *Blaxius^2 A:B-R, B:B-R* Interlink -> Orelo MKII Active Open Baffle Horn Speakers.
Removed Switching Supplies from everywhere (also from the PC).

For a general PC :
W10-10586.0 - May 2016 (2.05+)
*XXHighEnd PC -> I7 3930k with Hyperthreading On (12 cores)* @~500MHz, 16GB, Windows 10 Pro 64 bit build 10586.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/1/1/1 / Q1Factor = 1 / Dev.Buffer = 4096 / ClockRes = 1ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = 0.10  (max 60) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / All Services Off / Keep LAN - Not Persist / WallPaper On / OSD On / Running Time Off / Minimize OS / XTweaks : Balanced Load = *43* / Nervous Rate = 1 / Cool when Idle = 1 / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = *Optimal* / Time Stability = *Stable* / Custom Filter *Low* 705600 / -> USB3 *from MoBo* -> Clairixa USB 15cm -> Intona Isolator -> Clairixa USB 1m80 -> 24/768 Phasure NOS1a 75B (BNC Out) async USB DAC, Driver v1.0.4b (4ms) -> Blaxius BNC interlink *-> B'ASS Current Amplifier /w Level4 -> Blaxius Interlink* -> Orelo MKII Active Open Baffle Horn Speakers.
Removed Switching Supplies from everywhere.

Global Moderator
Rmalits
Audio Loudspeaker
*
Offline Offline

Posts: 104


View Profile
« Reply #64 on: September 13, 2019, 07:41:04 am »

Hi Peter,

as  release 2.11 of XXHE is on the way, I would like to ask you if a solution could be found with this new release for the cover art problem when using a NAS as music storage.

I am a happy user of your excelent technology for more than three years now, but all this time without seeing the cover art when playing unattended from my Synology NAS.

Therfore I again did some testing with the same results as described above some time ago:
- playing in attended mode, cover art is always there
- playing WAVE-files unattended, cover art is always there
- playing FLAC-files cover art does not show up in unattended mode

Something maybe new to this topic, I found out:
After loading an album in FLAC format into the playlist the folder.jpg on my synology NAS obvioulsly isn‘t closed by the operation system of the NAS. In this state it is for example not possible to rename or remove folder.jpg on the NAS.
When the same album in WAVE format is loaded into the playlist, folder.jpg does not stay open. It can be handler freely.

So, I guess - or better hope - that this could be the reason that the coverart is not shown when playing FLAC- files in unattended mode, because the OS of the NAS may not allow another access to folder.jpg.

Maybe a simple „close“ command after loading folder.jpg in XXHE would solve this long lasting problem.
Peter, is it possible that you include this kind of fix into release 2.11 ?

Kind regards
Richard
Logged

XXHighEnd Mach III Stealth LPS PC, Windows 10 Pro 64 bit build 14393.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 15/-/1/1/1/ Q1Factor = 20 / Dev.Buffer = 4096 / ClockRes = 15ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = 0.69 (max 120) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Use Remote Desktop / Keep LAN - Not Persist / WallPaper On / OSD Off / Running Time Off / Minimize OS / XTweaks : Balanced Load = 35 / Nervous Rate = 12 / Arc Prediction Filtering (16x)
PeterSt
Administrator
High Grade Audiophile
*****
Offline Offline

Posts: 15547



View Profile Email
« Reply #65 on: September 16, 2019, 12:29:16 pm »

Hi Richard,

That could be crucial additional information.
So I put it in the Todo and we will see what happens. I am going to try to make something of it …

Best regards,
Peter

Logged

For the Stealth III LPS PC :
W10-14393.0 - Oct 31, 2018 (2.10)
XXHighEnd Mach III Stealth LPS PC -> Xeon Scalable 14/28 core with Hyperthreading On (set to 10/20 cores) @~660MHz, 48GB, Windows 10 Pro 64 bit build 14393.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 30/-/1/1/1/ Q1Factor = 10 / Dev.Buffer = 4096 / ClockRes = 15ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = 140.19  (max 140.19) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / Stop Desktop, Remaining, WASAPI and W10 services / Use Remote Desktop / Keep LAN - Not Persist / WallPaper On / OSD Off (!) / Running Time Off / Minimize OS / XTweaks : Balanced Load = 35 / Nervous Rate = 10 / Cool when Idle = n.a / Provide Stable Power = 0 / Utilize Cores always = 1 / Time Performance Index = Optimal / Time Stability = Stable / *Arc Prediction Filtering (16x)* / Always Clear Proxy before Playback = On -> USB3 from MoBo -> Lush^2*A:B-W-Y-R, B:B-W-R* USB 1m00 -> Phisolator 24/768 Phasure NOS1a/G3 75B (BNC Out) async USB DAC, Driver v1.0.4b (16ms) -> B'ASS Current Amplifier -> *Blaxius^2 A:B-R, B:B-R* Interlink -> Orelo MKII Active Open Baffle Horn Speakers.
Removed Switching Supplies from everywhere (also from the PC).

For a general PC :
W10-10586.0 - May 2016 (2.05+)
*XXHighEnd PC -> I7 3930k with Hyperthreading On (12 cores)* @~500MHz, 16GB, Windows 10 Pro 64 bit build 10586.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/1/1/1 / Q1Factor = 1 / Dev.Buffer = 4096 / ClockRes = 1ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = 0.10  (max 60) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / All Services Off / Keep LAN - Not Persist / WallPaper On / OSD On / Running Time Off / Minimize OS / XTweaks : Balanced Load = *43* / Nervous Rate = 1 / Cool when Idle = 1 / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = *Optimal* / Time Stability = *Stable* / Custom Filter *Low* 705600 / -> USB3 *from MoBo* -> Clairixa USB 15cm -> Intona Isolator -> Clairixa USB 1m80 -> 24/768 Phasure NOS1a 75B (BNC Out) async USB DAC, Driver v1.0.4b (4ms) -> Blaxius BNC interlink *-> B'ASS Current Amplifier /w Level4 -> Blaxius Interlink* -> Orelo MKII Active Open Baffle Horn Speakers.
Removed Switching Supplies from everywhere.

Global Moderator
Rmalits
Audio Loudspeaker
*
Offline Offline

Posts: 104


View Profile
« Reply #66 on: September 21, 2019, 09:38:19 am »

Thanks a lot, Peter!

That would be great!  Tadaaaa

Best regards
Richard
Logged

XXHighEnd Mach III Stealth LPS PC, Windows 10 Pro 64 bit build 14393.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 15/-/1/1/1/ Q1Factor = 20 / Dev.Buffer = 4096 / ClockRes = 15ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = 0.69 (max 120) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Use Remote Desktop / Keep LAN - Not Persist / WallPaper On / OSD Off / Running Time Off / Minimize OS / XTweaks : Balanced Load = 35 / Nervous Rate = 12 / Arc Prediction Filtering (16x)
Pages: 1 2 3 4 [5]  All
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1 RC2 | SMF © 2001-2005, Lewis Media Valid XHTML 1.0! Valid CSS!
Page created in 0.083 seconds with 19 queries.