XXHighEnd - The Ultra HighEnd Audio Player
August 20, 2017, 01:10:45 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: August 6, 2017 : Phasure Webshop open ! Go to the Shop
Search current board structure only !!
Home Help Search Login Register
Pages: [1]
Print
Author Topic: Moving entire galleries  (Read 742 times)
0 Members and 0 Guests are viewing this topic.
charliemb
Audio Enthusiast
**
Offline Offline

Posts: 235


View Profile
« on: July 28, 2017, 10:48:38 pm »

Hi Peter

1. How do I move all contents of my Nice Stuff gallery to the Show gallery?

2. Also, how do I delete a duplicate item within a gallery? 

The situation for 2 is that if I like a track I hit Alt-c.  But it turns out I do that multiple times over the course of years because I can't remember whether or not I've hit alt-c before.  So I end up with unwanted duplicates. 

Perhaps there is a new setting brewing here:
  • a "De-duplicate Galleries" button?  This button can clean everything up automatically, or
  • a "Prevent duplicates" button?  This can leave galleries as they are but check to make sure that new entries don't already exist

Thanks for your consideration

Charlie
Logged

July 2015   *=appear to be critical:
XXHighEnd PC (i7 3930K) Hyperthreading On (12 cores) underclocked to *2.5GHz*, 16GB, Windows 7 Ultimate64 SP1 on 2.5 SATA2 spinning disk, XX on 2.5 OS disk, music on 3.5 SATA3 7200 RPM.  Motherboard BIOS settings: BCLK = 100 MHz / Intel Speed Step = OFF / Max Clock Ratio = 25 / Allow OS to change ratio = OFF. 
XXHighEnd 2.01 Adaptive / Q1/3/4/5 = 6/1/1/1 / Q1x = 1 / Dev.Buffer = 4096 / ClockRes = 1ms / Straight Contiguous / SFS = *60* (max 150) / Playerprio = Low (or below normal) / ThreadPrio = High / Core3-5 / *No Playback Drive* / *No RAMDISK* (the built-in one, have not tried IMdisk) / UnAttended / most services Off, WASAPI on  / Minimize OS / XTweaks set to v2.01 Defaults / *8x 384 Custom Filters* (High 23380 Hz)
DAC: 384KHz Wyred 4 Sound DAC2 DSDse set to default PCM Rolloff=FAST (the SLOW setting does not sufficiently filter out the noise shaping of the DAC), and no preamp
PeterSt
Administrator
High Grade Audiophile
*****
Offline Offline

Posts: 14369



View Profile
« Reply #1 on: July 29, 2017, 06:24:41 am »

Quote
1. How do I move all contents of my Nice Stuff gallery to the Show gallery?

Charlie, only with trickery I would not even be able to accomplish myself.
So say it can't.

Quote
2. Also, how do I delete a duplicate item within a gallery?

Just delete it. Notice that ubnder RighClick on the Library Item, there's a "More Gallery functions" option near the bottom in the context menu, and there reside the functions you seek for.

Quote
The situation for 2 is that if I like a track I hit Alt-c.  But it turns out I do that multiple times over the course of years because I can't remember whether or not I've hit alt-c before.  So I end up with unwanted duplicates.

No, that is not how it works (or indeed you'll get mad). So I am afraid you already "manipulated" outside of XXHighEnd's functions, like copying Gallery folders or renaming them etc. etc. via Explorer.
Say that it is another subject how to get this right again. This too will be quite impossible, depending on the damaga done. Anyway :

When you use one of the "Put to Gallery" gallery functions, it creates meta data of the album in the Gallery Folder with the same name (but prefixed with the Gallery itself). Do this again, and it just does it again. No duplicate can emerge. However, copy the Original Location (folder) to elsewhere, play that and again use Alt-c etc. and you have the Gallery entry twice. Well, not really, because you have the Original also twice. So this is still consistent.
Now Rename the Original with Explorer to another name and things will go bad on you; you now renamed the Original but did not rename the Gallery, which you btw can not even do because there's also the metadata itself with related contents). Anyway, if you now plat from this newly named (location) and use Alt-c again, you indeed have two entries, but the old one is actually obsolete.
Do the problem really is that after the rename, the old one is a floating entry with reference to something which does not exist any more.

This is your base for understanding; it solves nothing (but if you have concrete questions, shoot them).

Peter
Logged

For the Stealth LPS PC :
W10-14393.0 - December 23 2016 (2.07)
*XXHighEnd Mach II Stealth LPS PC -> Xeon E5 2640v4 with Hyperthreading On (20 cores)* @~720MHz, 32GB, Windows 10 Pro 64 bit build 14393.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/0/1/0/ Q1Factor = 10 / Dev.Buffer = 4096 / ClockRes = 1ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = 120  (max 120) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / All Services Off / Keep LAN - Not Persist / WallPaper On / OSD On / Running Time Off / Minimize OS / XTweaks : Balanced Load = 43 / Nervous Rate = 100 / Cool when Idle = n.a / Provide Stable Power = 0 / Utilize Cores always = 1 / Time Performance Index = *Optimal* / Time Stability = *Stable* / Custom Filter *Low* 705600 / -> USB3 *from MoBo* -> *Clairixa USB 1m80* -> *Phisolator* 24/768 Phasure NOS1a 75B (BNC Out) async USB DAC, Driver v1.0.4b (4ms) -> Blaxius BNC interlink *-> B'ASS Current Amplifier /w Level4 -> Blaxius Interlink* -> Orelo MKII Active Open Baffle Horn Speakers.
Removed Switching Supplies from everywhere (also from the PC).

For a general PC :
W10-10586.0 - May 2016 (2.05+)
*XXHighEnd PC -> I7 3930k with Hyperthreading On (12 cores)* @~500MHz, 16GB, Windows 10 Pro 64 bit build 10586.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/1/1/1 / Q1Factor = 1 / Dev.Buffer = 4096 / ClockRes = 1ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = 0.10  (max 60) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / All Services Off / Keep LAN - Not Persist / WallPaper On / OSD On / Running Time Off / Minimize OS / XTweaks : Balanced Load = *43* / Nervous Rate = 1 / Cool when Idle = 1 / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = *Optimal* / Time Stability = *Stable* / Custom Filter *Low* 705600 / -> USB3 *from MoBo* -> Clairixa USB 15cm -> Intona Isolator -> Clairixa USB 1m80 -> 24/768 Phasure NOS1a 75B (BNC Out) async USB DAC, Driver v1.0.4b (4ms) -> Blaxius BNC interlink *-> B'ASS Current Amplifier /w Level4 -> Blaxius Interlink* -> Orelo MKII Active Open Baffle Horn Speakers.
Removed Switching Supplies from everywhere.

Global Moderator
charliemb
Audio Enthusiast
**
Offline Offline

Posts: 235


View Profile
« Reply #2 on: July 29, 2017, 03:02:18 pm »

Quote
Quote
1. How do I move all contents of my Nice Stuff gallery to the Show gallery?

Charlie, only with trickery I would not even be able to accomplish myself.
So say it can't.

The need for this arises because I'm interested in individual tracks, not whole albums, and my understanding is that individual tracks are handled in the Show gallery.

Re deleting duplicates...
Quote
Just delete it. Notice that under RightClick on the Library Item, there's a "More Gallery functions" option near the bottom in the context menu, and there reside the functions you seek for.

I believe I tried that and it didn't work, as tested in the past by clearing and reloading and when I reloaded, duplicates appeared regardless.  Now maybe that was a cache issue or something like I needed to exit and restart xxHE.  I will have to reconfirm.

Quote
Quote
The situation for 2 is that if I like a track I hit Alt-c.  But it turns out I do that multiple times over the course of years because I can't remember whether or not I've hit alt-c before.  So I end up with unwanted duplicates.

No, that is not how it works (or indeed you'll get mad). So I am afraid you already "manipulated" outside of XXHighEnd's functions, like copying Gallery folders or renaming them etc. etc. via Explorer.
Say that it is another subject how to get this right again. This too will be quite impossible, depending on the damaga done. Anyway ...

I never copied Gallery folders, nor renamed them, nor moved them.  However, because rightClick functions were not working, I did try to use explorer to delete some.  But that didn't work because apparently, a duplicate Gallery metadata item is also placed in the "real" folder and from that it appears that the Gallery "repairs" itself.  [Frankly I don't like the idea that the real folder is littered with these Gallery files.  I'd prefer you create a folder and within that litter all you want, preferably a hidden folder.  Even more preferred would be,  don't touch the real folders at all, or at least have an option for that.]

The real / original folders and data and their locations on the disk have always been the same and have never changed.  Yet,  the filenames of the metadata files in the Galleries for these duplicates are indeed a little bit different.   That's a cliue.  Perhaps different versions of xxHE used different naming schemes?
Logged

July 2015   *=appear to be critical:
XXHighEnd PC (i7 3930K) Hyperthreading On (12 cores) underclocked to *2.5GHz*, 16GB, Windows 7 Ultimate64 SP1 on 2.5 SATA2 spinning disk, XX on 2.5 OS disk, music on 3.5 SATA3 7200 RPM.  Motherboard BIOS settings: BCLK = 100 MHz / Intel Speed Step = OFF / Max Clock Ratio = 25 / Allow OS to change ratio = OFF. 
XXHighEnd 2.01 Adaptive / Q1/3/4/5 = 6/1/1/1 / Q1x = 1 / Dev.Buffer = 4096 / ClockRes = 1ms / Straight Contiguous / SFS = *60* (max 150) / Playerprio = Low (or below normal) / ThreadPrio = High / Core3-5 / *No Playback Drive* / *No RAMDISK* (the built-in one, have not tried IMdisk) / UnAttended / most services Off, WASAPI on  / Minimize OS / XTweaks set to v2.01 Defaults / *8x 384 Custom Filters* (High 23380 Hz)
DAC: 384KHz Wyred 4 Sound DAC2 DSDse set to default PCM Rolloff=FAST (the SLOW setting does not sufficiently filter out the noise shaping of the DAC), and no preamp
PeterSt
Administrator
High Grade Audiophile
*****
Offline Offline

Posts: 14369



View Profile
« Reply #3 on: July 30, 2017, 11:23:43 am »

Charlie,

The majority of functions required for this - and so you can do all what's desired - only emerged way beyond the 2.01 you used.
Today it should be fairly complete because I don't recall having changed anything regarding this in the due 2.08. Maybe 2.07 also not any more.

We must also be carful about "nomenclature" by now, because the short keys changed.
AutoHotKeys (Remote Commands) Listing.
... And as it turns out, I don't even know them by heard any more because I always use the XXOSK.exe and use the remote + tap the shortcuts in there. Anyway :

What you can see in the link is that Alt-c has been deprecated and its major reason was that tracks could mix up with full albums. So this is explicitly dealt with in one of the  releasnote pages to the later versions. So if you have problems regarding that, it is justified (but I don't recall it to be a big deal, only confusing).

Anyway, what you are looking for is Alt-z, which puts to (the by you set) "Demo" Gallery. Change the relevant field from what you currently use for Show or IOW Alt-w.
The specialy of Show is that it can be dynamically changed (while using the remote). No "Show" is the same ... (or whatver reason you have yourself).
Alt-h copies to Nice Stuff and that is now always the whole Album.

Also notice Ctrl-Alt-h and Ctrl-Alt-z.
Or Ctrl-Alt-r - also crucial.

I hope this helps you a little ...
Peter
Logged

For the Stealth LPS PC :
W10-14393.0 - December 23 2016 (2.07)
*XXHighEnd Mach II Stealth LPS PC -> Xeon E5 2640v4 with Hyperthreading On (20 cores)* @~720MHz, 32GB, Windows 10 Pro 64 bit build 14393.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/0/1/0/ Q1Factor = 10 / Dev.Buffer = 4096 / ClockRes = 1ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = 120  (max 120) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / All Services Off / Keep LAN - Not Persist / WallPaper On / OSD On / Running Time Off / Minimize OS / XTweaks : Balanced Load = 43 / Nervous Rate = 100 / Cool when Idle = n.a / Provide Stable Power = 0 / Utilize Cores always = 1 / Time Performance Index = *Optimal* / Time Stability = *Stable* / Custom Filter *Low* 705600 / -> USB3 *from MoBo* -> *Clairixa USB 1m80* -> *Phisolator* 24/768 Phasure NOS1a 75B (BNC Out) async USB DAC, Driver v1.0.4b (4ms) -> Blaxius BNC interlink *-> B'ASS Current Amplifier /w Level4 -> Blaxius Interlink* -> Orelo MKII Active Open Baffle Horn Speakers.
Removed Switching Supplies from everywhere (also from the PC).

For a general PC :
W10-10586.0 - May 2016 (2.05+)
*XXHighEnd PC -> I7 3930k with Hyperthreading On (12 cores)* @~500MHz, 16GB, Windows 10 Pro 64 bit build 10586.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/1/1/1 / Q1Factor = 1 / Dev.Buffer = 4096 / ClockRes = 1ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = 0.10  (max 60) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / All Services Off / Keep LAN - Not Persist / WallPaper On / OSD On / Running Time Off / Minimize OS / XTweaks : Balanced Load = *43* / Nervous Rate = 1 / Cool when Idle = 1 / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = *Optimal* / Time Stability = *Stable* / Custom Filter *Low* 705600 / -> USB3 *from MoBo* -> Clairixa USB 15cm -> Intona Isolator -> Clairixa USB 1m80 -> 24/768 Phasure NOS1a 75B (BNC Out) async USB DAC, Driver v1.0.4b (4ms) -> Blaxius BNC interlink *-> B'ASS Current Amplifier /w Level4 -> Blaxius Interlink* -> Orelo MKII Active Open Baffle Horn Speakers.
Removed Switching Supplies from everywhere.

Global Moderator
charliemb
Audio Enthusiast
**
Offline Offline

Posts: 235


View Profile
« Reply #4 on: August 03, 2017, 01:05:19 am »

Hi Peter

If I understood correctly,  both Show (alt-w) and Demo (alt-z) deal with tracks, not whole albums.  True?

If true, then I can use either.  I still have no Gallery set for Show.   Up until now I've only used NiceStuff and Demo.   Unfortunately, I've been using Demo for tracks that are so-called "bad" recordings,  for example where there is obviously mic distortion etc.   I use these tracks to see how different settings affect "bad" recordings.

So probably the best thing I can do is starting using Show, and load the individual tracks of Nice Stuff and save them to Show;  then remove them from Nice Stuff all within xxHE.

-OR- One possible interpretation of what you wrote above, namely this...

Quote
Anyway, what you are looking for is Alt-z, which puts to (the by you set) "Demo" Gallery. Change the relevant field from what you currently use for Show or IOW Alt-w.
The specialy of Show is that it can be dynamically changed (while using the remote). No "Show" is the same ... (or whatver reason you have yourself).

... is that I can use the field for Show to point to the c:\xxHighEnd\Nice Stuff gallery ...  which would allow me to do what I want without moving anything just by using alt-w and by working from the Show gallery which on the disk is actually the Nice Stuff gallery's location.   (Not sure about this at all.)

Yes?  No?
Logged

July 2015   *=appear to be critical:
XXHighEnd PC (i7 3930K) Hyperthreading On (12 cores) underclocked to *2.5GHz*, 16GB, Windows 7 Ultimate64 SP1 on 2.5 SATA2 spinning disk, XX on 2.5 OS disk, music on 3.5 SATA3 7200 RPM.  Motherboard BIOS settings: BCLK = 100 MHz / Intel Speed Step = OFF / Max Clock Ratio = 25 / Allow OS to change ratio = OFF. 
XXHighEnd 2.01 Adaptive / Q1/3/4/5 = 6/1/1/1 / Q1x = 1 / Dev.Buffer = 4096 / ClockRes = 1ms / Straight Contiguous / SFS = *60* (max 150) / Playerprio = Low (or below normal) / ThreadPrio = High / Core3-5 / *No Playback Drive* / *No RAMDISK* (the built-in one, have not tried IMdisk) / UnAttended / most services Off, WASAPI on  / Minimize OS / XTweaks set to v2.01 Defaults / *8x 384 Custom Filters* (High 23380 Hz)
DAC: 384KHz Wyred 4 Sound DAC2 DSDse set to default PCM Rolloff=FAST (the SLOW setting does not sufficiently filter out the noise shaping of the DAC), and no preamp
PeterSt
Administrator
High Grade Audiophile
*****
Offline Offline

Posts: 14369



View Profile
« Reply #5 on: August 03, 2017, 01:35:34 pm »

Hi Charlie,

Your second option may be a tricky one, as at this moment I can not oversee what the consequences are for something which was "abum bounded" (Nice Stuff) and "track bounded" (Show / Demo).

The first option seems more safe to me. Thus indeed :

Quote
So probably the best thing I can do is starting using Show, and load the individual tracks of Nice Stuff and save them to Show;  then remove them from Nice Stuff all within xxHE.

Because Show can be appointed dynamically (even during playing), Ot would "originally" be my idea that in there you also have a Bad Tracks. But this might not be the best idea at all, because you can run into bad tracks at any time and want to act fast (press Alt-z (Demo) - done).

Of course you have also seen the Ctrl-Alt-h and Ctrl-Alt-z (Album and Tracks respectively) buttons on the XXOSK.Exe, which imply dynamic allocation to anything (via "select via Tablet" - just look in there and you wil grasp it).

Lastly (because it may be confusing or look dangerous when you are not used to it), use the "Remove Gallery Selection from his Gallery" when you want to remove all the entries from that Gallery you just copied to another. But be sure to select the proper Gallery first !
And notice that what I refer to here is from within the Library Area (use [ L ] in the top). I think it is obvious, but just saying ...

Peter
Logged

For the Stealth LPS PC :
W10-14393.0 - December 23 2016 (2.07)
*XXHighEnd Mach II Stealth LPS PC -> Xeon E5 2640v4 with Hyperthreading On (20 cores)* @~720MHz, 32GB, Windows 10 Pro 64 bit build 14393.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/0/1/0/ Q1Factor = 10 / Dev.Buffer = 4096 / ClockRes = 1ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = 120  (max 120) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / All Services Off / Keep LAN - Not Persist / WallPaper On / OSD On / Running Time Off / Minimize OS / XTweaks : Balanced Load = 43 / Nervous Rate = 100 / Cool when Idle = n.a / Provide Stable Power = 0 / Utilize Cores always = 1 / Time Performance Index = *Optimal* / Time Stability = *Stable* / Custom Filter *Low* 705600 / -> USB3 *from MoBo* -> *Clairixa USB 1m80* -> *Phisolator* 24/768 Phasure NOS1a 75B (BNC Out) async USB DAC, Driver v1.0.4b (4ms) -> Blaxius BNC interlink *-> B'ASS Current Amplifier /w Level4 -> Blaxius Interlink* -> Orelo MKII Active Open Baffle Horn Speakers.
Removed Switching Supplies from everywhere (also from the PC).

For a general PC :
W10-10586.0 - May 2016 (2.05+)
*XXHighEnd PC -> I7 3930k with Hyperthreading On (12 cores)* @~500MHz, 16GB, Windows 10 Pro 64 bit build 10586.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/1/1/1 / Q1Factor = 1 / Dev.Buffer = 4096 / ClockRes = 1ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = 0.10  (max 60) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / All Services Off / Keep LAN - Not Persist / WallPaper On / OSD On / Running Time Off / Minimize OS / XTweaks : Balanced Load = *43* / Nervous Rate = 1 / Cool when Idle = 1 / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = *Optimal* / Time Stability = *Stable* / Custom Filter *Low* 705600 / -> USB3 *from MoBo* -> Clairixa USB 15cm -> Intona Isolator -> Clairixa USB 1m80 -> 24/768 Phasure NOS1a 75B (BNC Out) async USB DAC, Driver v1.0.4b (4ms) -> Blaxius BNC interlink *-> B'ASS Current Amplifier /w Level4 -> Blaxius Interlink* -> Orelo MKII Active Open Baffle Horn Speakers.
Removed Switching Supplies from everywhere.

Global Moderator
Pages: [1]
Print
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1 RC2 | SMF © 2001-2005, Lewis Media Valid XHTML 1.0! Valid CSS!
Page created in 0.315 seconds with 19 queries.