XXHighEnd - The Ultra HighEnd Audio Player
January 16, 2021, 10:42:19 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: August 6, 2017 : Phasure Webshop open ! Go to the Shop
Search current board structure only !!  
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: Tidal: error when trying to search for a playlist  (Read 315 times)
0 Members and 0 Guests are viewing this topic.
Erwin
Audio Loudspeaker
*
Offline Offline

Posts: 3


View Profile Email
« on: December 31, 2020, 04:52:35 pm »

Hello there,

this is my first topic on this forum. Guess i will make an introduction some time, because i will probably hang around here now and then.
At first, thank you all for filling this forum with lots of information, i managed to get XXhighend going on RAMdisks on a PC i built, install drivers for my recently acquired Phasure DAC, all by searching these forums and reading Peter's tutorials.

i also got the Tidal functionality going in XXhighend, that is really a function i would not like to do without. Albums and Tracks are coming in just fine. I also would really like to prepare existing, and my own playlists, which should be possible since XXhighend 2.08 (see the release topic here: http://www.phasure.com/index.php?topic=3887.0)

but when i follow the described procedure of pasting the playlist link into the album/general field, and press search, i get this:
The remote server returned an error: (400)
Bad Request

It happens with all playlists, also the ones which i see mentioned on this forum.

i already tried to alter the date in the tidalsession.dat file because i noticed that could help a similar error, but that does not help.

i am using XXHighend 2.11a, upgraded from 2.10

Any ideas?


* tidalerror1.PNG (29.83 KB, 842x605 - viewed 52 times.)
Logged
briefremarks
Audio Enthusiast
**
Offline Offline

Posts: 230


View Profile
« Reply #1 on: January 01, 2021, 06:10:15 am »

Erwin,

XXHE will work with Tidal curated playlists, but not your own custom created playlists.  Can you confirm that you are able to prepare Tidal playlists?

Ramesh
Logged

Audio PC: Stealth III PC; RAM-OS W10 14393.0. 
XXHE version 2.11.
Music Server: XXHE PC, RDC to Audio PC
XXHE settings: Q1/xQ1 5/x15, Q3/4/5 1/1/1, SFS 20.69 (Max 120), Clock Res 15ms, Core Scheme:3-5, Driver Buffer 16ms, Balanced Load 35, Nervous Rate 10.
Audio PC -> Lush^3 USB (A: BYR; B: WY&RG-> NOS1(a,75B, G3) -> Blaxius^2 (A:BR, B: BR) -> Orelo Mk II active speakers
PeterSt
Administrator
High Grade Audiophile
*****
Offline Offline

Posts: 15729



View Profile Email
« Reply #2 on: January 01, 2021, 12:30:21 pm »


Hi Erwin,

I am afraid you are right - it does not work any more; Something must have changed on Tidal's end ...

I will look into it.
Kind regards, welcome and thanks !
Peter
Logged

For the Stealth III LPS PC :
W10-14393.0 - April 1, 2020 (2.11)
XXHighEnd Mach III Stealth LPS PC -> Xeon Scalable 14/28 core with Hyperthreading On (set to 14/28 cores in BIOS and set to 10/20 cores via Boot Menu) @~660MHz, 48GB, Windows 10 Pro 64 bit build 14393.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/1/1/1/ Q1Factor = 1 / Dev.Buffer = 4096 / ClockRes = 15ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = *20.69*  (max *20.69*) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / Stop Desktop, Remaining, WASAPI and W10 services / Use Remote Desktop / Keep LAN - Not Persist / WallPaper On / OSD Off (!) / Running Time Off / Minimize OS / XTweaks : Balanced Load = 52 / Nervous Rate = 10 / Cool when Idle = n.a / Provide Stable Power = 0 / Utilize Cores always = 1 / Time Performance Index = Optimal / Time Stability = Stable / *Custom Filtering* *High 3.72%* (16x) / Always Clear Proxy before Playback = On -> USB3 from MoBo -> *Lush^3*
A: B-Y-R, B: W-Y & R-G* USB 1m00 -> Phisolator 24/768 Phasure NOS1a/G3 75B (BNC Out) async USB DAC, Driver v1.0.4b (16ms) -> B'ASS Current Amplifier -> Blaxius^2 A:B-R, B:B-R Interlink -> Orelo MKII Active Open Baffle Horn Speakers. ET^2 Ethernet from Mach III to Music Server PC (RDC Control).
Removed Switching Supplies from everywhere (also from the PC).

For a general PC :
W10-10586.0 - May 2016 (2.05+)
*XXHighEnd PC -> I7 3930k with Hyperthreading On (12 cores)* @~500MHz, 16GB, Windows 10 Pro 64 bit build 10586.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/1/1/1 / Q1Factor = 1 / Dev.Buffer = 4096 / ClockRes = 1ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = 0.10  (max 60) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / All Services Off / Keep LAN - Not Persist / WallPaper On / OSD On / Running Time Off / Minimize OS / XTweaks : Balanced Load = *43* / Nervous Rate = 1 / Cool when Idle = 1 / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = *Optimal* / Time Stability = *Stable* / Custom Filter *Low* 705600 / -> USB3 *from MoBo* -> Clairixa USB 15cm -> Intona Isolator -> Clairixa USB 1m80 -> 24/768 Phasure NOS1a 75B (BNC Out) async USB DAC, Driver v1.0.4b (4ms) -> Blaxius BNC interlink *-> B'ASS Current Amplifier /w Level4 -> Blaxius Interlink* -> Orelo MKII Active Open Baffle Horn Speakers.
Removed Switching Supplies from everywhere.

Global Moderator
Erwin
Audio Loudspeaker
*
Offline Offline

Posts: 3


View Profile Email
« Reply #3 on: January 01, 2021, 01:10:01 pm »

Ah darn i was hoping it would be a little thing. Thanks for looking in to it, i hope it is an easy fix!

Erwin
Logged
PeterSt
Administrator
High Grade Audiophile
*****
Offline Offline

Posts: 15729



View Profile Email
« Reply #4 on: January 01, 2021, 05:45:55 pm »


Quote
i hope it is an easy fix!

No, it is not at all.
They changed things in such a fashion that I can't see through what *I* need to do to get it working again. This is all related to how Tidal at first messed up with all sorts of anomalies in there, and how I had to tweak all sorts of things to get it working. Notice that Playlist were not available really to the "API" back at the time, and that only a year or so (?) ago the Tidal app itself could show the individual underlaying albums, while XXHighEnd could do that from about the introduction of Playlists.
It seems that they now corrected all the anomalies they put in themselves, without any documentation on the how or what.

The worst is that normally a programmer (me) could look in old parts of the code to see what he/she did wrong since the introduction of feature / version XYZ - hence what was changed. But in this case the change is external and there is no "relative" code in order. It just fails (at the call of the web/API of them).

After a lot of hoopla I managed to retrieve the Playlist again, but the means of obtaining the tracks in there has changed too and I just can't het hold of the way how to do it (mind you, from within my own environment which is quite "huge").

It could be the end of Tidal Playlists ...

Peter
Logged

For the Stealth III LPS PC :
W10-14393.0 - April 1, 2020 (2.11)
XXHighEnd Mach III Stealth LPS PC -> Xeon Scalable 14/28 core with Hyperthreading On (set to 14/28 cores in BIOS and set to 10/20 cores via Boot Menu) @~660MHz, 48GB, Windows 10 Pro 64 bit build 14393.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/1/1/1/ Q1Factor = 1 / Dev.Buffer = 4096 / ClockRes = 15ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = *20.69*  (max *20.69*) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / Stop Desktop, Remaining, WASAPI and W10 services / Use Remote Desktop / Keep LAN - Not Persist / WallPaper On / OSD Off (!) / Running Time Off / Minimize OS / XTweaks : Balanced Load = 52 / Nervous Rate = 10 / Cool when Idle = n.a / Provide Stable Power = 0 / Utilize Cores always = 1 / Time Performance Index = Optimal / Time Stability = Stable / *Custom Filtering* *High 3.72%* (16x) / Always Clear Proxy before Playback = On -> USB3 from MoBo -> *Lush^3*
A: B-Y-R, B: W-Y & R-G* USB 1m00 -> Phisolator 24/768 Phasure NOS1a/G3 75B (BNC Out) async USB DAC, Driver v1.0.4b (16ms) -> B'ASS Current Amplifier -> Blaxius^2 A:B-R, B:B-R Interlink -> Orelo MKII Active Open Baffle Horn Speakers. ET^2 Ethernet from Mach III to Music Server PC (RDC Control).
Removed Switching Supplies from everywhere (also from the PC).

For a general PC :
W10-10586.0 - May 2016 (2.05+)
*XXHighEnd PC -> I7 3930k with Hyperthreading On (12 cores)* @~500MHz, 16GB, Windows 10 Pro 64 bit build 10586.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/1/1/1 / Q1Factor = 1 / Dev.Buffer = 4096 / ClockRes = 1ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = 0.10  (max 60) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / All Services Off / Keep LAN - Not Persist / WallPaper On / OSD On / Running Time Off / Minimize OS / XTweaks : Balanced Load = *43* / Nervous Rate = 1 / Cool when Idle = 1 / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = *Optimal* / Time Stability = *Stable* / Custom Filter *Low* 705600 / -> USB3 *from MoBo* -> Clairixa USB 15cm -> Intona Isolator -> Clairixa USB 1m80 -> 24/768 Phasure NOS1a 75B (BNC Out) async USB DAC, Driver v1.0.4b (4ms) -> Blaxius BNC interlink *-> B'ASS Current Amplifier /w Level4 -> Blaxius Interlink* -> Orelo MKII Active Open Baffle Horn Speakers.
Removed Switching Supplies from everywhere.

Global Moderator
Erwin
Audio Loudspeaker
*
Offline Offline

Posts: 3


View Profile Email
« Reply #5 on: January 01, 2021, 09:26:33 pm »

well then, maybe they will create some good documentation sometime... The change on the tidal side is only made somewhere in the last few weeks i think?

i hope you get it working again sometime!

Logged
PeterSt
Administrator
High Grade Audiophile
*****
Offline Offline

Posts: 15729



View Profile Email
« Reply #6 on: January 02, 2021, 05:43:17 am »


All,

Can anyone tell me when it was the last time the Playlists worked ?
For myself it must have been more than a year ago, so I can't tell.

Thanks,
Peter
Logged

For the Stealth III LPS PC :
W10-14393.0 - April 1, 2020 (2.11)
XXHighEnd Mach III Stealth LPS PC -> Xeon Scalable 14/28 core with Hyperthreading On (set to 14/28 cores in BIOS and set to 10/20 cores via Boot Menu) @~660MHz, 48GB, Windows 10 Pro 64 bit build 14393.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/1/1/1/ Q1Factor = 1 / Dev.Buffer = 4096 / ClockRes = 15ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = *20.69*  (max *20.69*) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / Stop Desktop, Remaining, WASAPI and W10 services / Use Remote Desktop / Keep LAN - Not Persist / WallPaper On / OSD Off (!) / Running Time Off / Minimize OS / XTweaks : Balanced Load = 52 / Nervous Rate = 10 / Cool when Idle = n.a / Provide Stable Power = 0 / Utilize Cores always = 1 / Time Performance Index = Optimal / Time Stability = Stable / *Custom Filtering* *High 3.72%* (16x) / Always Clear Proxy before Playback = On -> USB3 from MoBo -> *Lush^3*
A: B-Y-R, B: W-Y & R-G* USB 1m00 -> Phisolator 24/768 Phasure NOS1a/G3 75B (BNC Out) async USB DAC, Driver v1.0.4b (16ms) -> B'ASS Current Amplifier -> Blaxius^2 A:B-R, B:B-R Interlink -> Orelo MKII Active Open Baffle Horn Speakers. ET^2 Ethernet from Mach III to Music Server PC (RDC Control).
Removed Switching Supplies from everywhere (also from the PC).

For a general PC :
W10-10586.0 - May 2016 (2.05+)
*XXHighEnd PC -> I7 3930k with Hyperthreading On (12 cores)* @~500MHz, 16GB, Windows 10 Pro 64 bit build 10586.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/1/1/1 / Q1Factor = 1 / Dev.Buffer = 4096 / ClockRes = 1ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = 0.10  (max 60) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / All Services Off / Keep LAN - Not Persist / WallPaper On / OSD On / Running Time Off / Minimize OS / XTweaks : Balanced Load = *43* / Nervous Rate = 1 / Cool when Idle = 1 / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = *Optimal* / Time Stability = *Stable* / Custom Filter *Low* 705600 / -> USB3 *from MoBo* -> Clairixa USB 15cm -> Intona Isolator -> Clairixa USB 1m80 -> 24/768 Phasure NOS1a 75B (BNC Out) async USB DAC, Driver v1.0.4b (4ms) -> Blaxius BNC interlink *-> B'ASS Current Amplifier /w Level4 -> Blaxius Interlink* -> Orelo MKII Active Open Baffle Horn Speakers.
Removed Switching Supplies from everywhere.

Global Moderator
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1 RC2 | SMF © 2001-2005, Lewis Media Valid XHTML 1.0! Valid CSS!
Page created in 0.056 seconds with 20 queries.