XXHighEnd - The Ultra HighEnd Audio Player
September 23, 2021, 10:19:28 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: August 6, 2017 : Phasure Webshop open ! Go to the Shop
Search current board structure only !!  
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: ActiveX Error Message  (Read 832 times)
0 Members and 1 Guest are viewing this topic.
vhs
Audio Loudspeaker
*
Offline Offline

Posts: 5


View Profile
« on: July 01, 2021, 12:26:35 pm »

First of all, XXHighEnd 2.11a is the best music software so far.

I am running into a problem. I have not yet activated but XXHighEnd always shut down by itself and pop up the message:

"ActiveX Control "....." cannot be instantiated because the current thread is not in a single-threaded apartment."

I am using Windows Server 2019 Core mode with AO3.

Your response will be highly appreciated.


* rsz_activex.jpg (959.61 KB, 2016x1512 - viewed 102 times.)
Logged
PeterSt
Administrator
High Grade Audiophile
*****
Offline Offline

Posts: 15844



View Profile Email
« Reply #1 on: July 01, 2021, 05:57:33 pm »


Hey there vhs,

Well, not that I knew about this error, but it will only occur because of the demo version "quitting". So between 6 minutes and 30 minutes or so, the demo version shuts down automatically, and apparently there something goes wrong now. But it would have quitted anyway ...

Thank you very much for mentioning this and of course I am going to look into it !
Peter
Logged

For the Stealth III LPS PC :
W10-14393.0 - Januari 24, 2021 (2.11)
XXHighEnd Mach III Stealth LPS PC -> Xeon Scalable 14/28 core with Hyperthreading On (set to 14/28 cores in BIOS and set to 10/20 cores via Boot Menu) @~660MHz, 48GB, Windows 10 Pro 64 bit build 14393.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/*0*/*0*/*0*/ Q1Factor = 1 / Dev.Buffer = 4096 / ClockRes = 15ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = 20.69  (max 20.69) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / Stop Desktop, Remaining, WASAPI and W10 services / Use Remote Desktop / Keep LAN - Not Persist / WallPaper On / OSD Off (!) / Running Time Off / Minimize OS / XTweaks : Balanced Load = *68* / Nervous Rate = 10 / Cool when Idle = n.a / Provide Stable Power = *1* / Utilize Cores always = 1 / Time Performance Index = Optimal / Time Stability = Stable / Custom Filtering *Low* (16x) / Always Clear Proxy before Playback = On -> USB3 from MoBo -> Lush^3
A: W-Y-R-G, B: W-Y-R* USB 1m00 -> Phisolator 24/768 Phasure NOS1a/G3 75B (BNC Out) async USB DAC, Driver v1.0.4b (16ms) -> B'ASS Current Amplifier -> Blaxius*^2.5* A:B-G, B:B-G Interlink -> Orelo MKII Active Open Baffle Horn Speakers. ET^2 Ethernet from Mach III to Music Server PC (RDC Control).
Removed Switching Supplies from everywhere (also from the PC).

For a general PC :
W10-10586.0 - May 2016 (2.05+)
*XXHighEnd PC -> I7 3930k with Hyperthreading On (12 cores)* @~500MHz, 16GB, Windows 10 Pro 64 bit build 10586.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/1/1/1 / Q1Factor = 1 / Dev.Buffer = 4096 / ClockRes = 1ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = 0.10  (max 60) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / All Services Off / Keep LAN - Not Persist / WallPaper On / OSD On / Running Time Off / Minimize OS / XTweaks : Balanced Load = *43* / Nervous Rate = 1 / Cool when Idle = 1 / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = *Optimal* / Time Stability = *Stable* / Custom Filter *Low* 705600 / -> USB3 *from MoBo* -> Clairixa USB 15cm -> Intona Isolator -> Clairixa USB 1m80 -> 24/768 Phasure NOS1a 75B (BNC Out) async USB DAC, Driver v1.0.4b (4ms) -> Blaxius BNC interlink *-> B'ASS Current Amplifier /w Level4 -> Blaxius Interlink* -> Orelo MKII Active Open Baffle Horn Speakers.
Removed Switching Supplies from everywhere.

Global Moderator
vhs
Audio Loudspeaker
*
Offline Offline

Posts: 5


View Profile
« Reply #2 on: July 02, 2021, 04:23:57 am »


Hey there vhs,

Well, not that I knew about this error, but it will only occur because of the demo version "quitting". So between 6 minutes and 30 minutes or so, the demo version shuts down automatically, and apparently there something goes wrong now. But it would have quitted anyway ...

Thank you very much for mentioning this and of course I am going to look into it !
Peter

Thx Peter

I guess I find the culprit of that ActiveX error message.

As I am using dual Xeon Scalable 4214 (12cores) of my music server, I adjusted the CPU Affinities of "XXHighEnd.exe" & "XXEngine3.exe" to Core 24-47, which were 12 cores in total.

After I readjusted the CPU Affinities of the above two processes to Core 24-43, which were 10 cores in total, ActiveX error message had never popped up again.

Cheers.

 



Logged
PeterSt
Administrator
High Grade Audiophile
*****
Offline Offline

Posts: 15844



View Profile Email
« Reply #3 on: July 02, 2021, 06:01:17 am »

Interesting ...

I don't think you can tweak like that because XXHighEnd does similar itself. Additionally I never took into account 2 processors in the sense of the total core count emerging by that. I mean, 12 + 12 would be 24 and 24 cores are not supported as far as I recall (I could look into the program - haha). So for example, 12 would be supported, 16 would be, 20 would be, 28 would be, 32 would be, 40 would be. But not 24 because I never saw a(n interesting) processor with 24 cores.
I would not think that things error out because of this (but apparently it can ?) but at least SQ would not be as intended (processor tasks would overlap / be mixed while all should be dedicated (no taskswitching implied)).

Quote
I adjusted the CPU Affinities of "XXHighEnd.exe" & "XXEngine3.exe" to Core

I think it is good to know (as said) that XXHighEnd does these things itself, and that possibly this implies anomaly because of the two levels this now occurs. Thus, you do this by means of TaskManager, and XXHighEnd does this internally. I'd say this will overrule but ... how will this unroll the stack ? Think of you quitting XXHighEnd and all nicely being undone (this really is so). But if XXHighEnd bails out because of demo-end time, then I am not so sure. It could be a too hard-quit falling back to ? ... Your settings ? ... I just never thought about this. And thus :

Interesting ...


PS: And thinking some more ... The Demo version does not allow explicit Core Appointment (see the according field in Settings for that), BUT one scenario is set anyway. It can well be that at "bailing out" this is not sufficiently taken into account. "If Demo then Don't reset Appointments because no User Settings applied". And this all in the midst of quitting playback right where it is (doing its job), which is different from you stopping playback where all is reset (mind you, for the whole system, not only the two XX executables). So yea, the bailing out with playback going on may not do even anything about resetting Affinities ... (call that a bug).
Logged

For the Stealth III LPS PC :
W10-14393.0 - Januari 24, 2021 (2.11)
XXHighEnd Mach III Stealth LPS PC -> Xeon Scalable 14/28 core with Hyperthreading On (set to 14/28 cores in BIOS and set to 10/20 cores via Boot Menu) @~660MHz, 48GB, Windows 10 Pro 64 bit build 14393.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/*0*/*0*/*0*/ Q1Factor = 1 / Dev.Buffer = 4096 / ClockRes = 15ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = 20.69  (max 20.69) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / Stop Desktop, Remaining, WASAPI and W10 services / Use Remote Desktop / Keep LAN - Not Persist / WallPaper On / OSD Off (!) / Running Time Off / Minimize OS / XTweaks : Balanced Load = *68* / Nervous Rate = 10 / Cool when Idle = n.a / Provide Stable Power = *1* / Utilize Cores always = 1 / Time Performance Index = Optimal / Time Stability = Stable / Custom Filtering *Low* (16x) / Always Clear Proxy before Playback = On -> USB3 from MoBo -> Lush^3
A: W-Y-R-G, B: W-Y-R* USB 1m00 -> Phisolator 24/768 Phasure NOS1a/G3 75B (BNC Out) async USB DAC, Driver v1.0.4b (16ms) -> B'ASS Current Amplifier -> Blaxius*^2.5* A:B-G, B:B-G Interlink -> Orelo MKII Active Open Baffle Horn Speakers. ET^2 Ethernet from Mach III to Music Server PC (RDC Control).
Removed Switching Supplies from everywhere (also from the PC).

For a general PC :
W10-10586.0 - May 2016 (2.05+)
*XXHighEnd PC -> I7 3930k with Hyperthreading On (12 cores)* @~500MHz, 16GB, Windows 10 Pro 64 bit build 10586.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/1/1/1 / Q1Factor = 1 / Dev.Buffer = 4096 / ClockRes = 1ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = 0.10  (max 60) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / All Services Off / Keep LAN - Not Persist / WallPaper On / OSD On / Running Time Off / Minimize OS / XTweaks : Balanced Load = *43* / Nervous Rate = 1 / Cool when Idle = 1 / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = *Optimal* / Time Stability = *Stable* / Custom Filter *Low* 705600 / -> USB3 *from MoBo* -> Clairixa USB 15cm -> Intona Isolator -> Clairixa USB 1m80 -> 24/768 Phasure NOS1a 75B (BNC Out) async USB DAC, Driver v1.0.4b (4ms) -> Blaxius BNC interlink *-> B'ASS Current Amplifier /w Level4 -> Blaxius Interlink* -> Orelo MKII Active Open Baffle Horn Speakers.
Removed Switching Supplies from everywhere.

Global Moderator
vhs
Audio Loudspeaker
*
Offline Offline

Posts: 5


View Profile
« Reply #4 on: July 02, 2021, 06:41:16 am »

Thx Peter for your explanation.

Yes it is indeed interesting.

I am using Process Lasso (PL) as well......

Without using PL to force the CPU affinities of "XXHighEnd.exe" & "XXEngine3.exe", these two processes will be automatically assigned to CPU 2-39 and CPU 0-1, respectively.

Cheers

Logged
nik.d
Audio Loudspeaker
*
Offline Offline

Posts: 170


View Profile
« Reply #5 on: July 02, 2021, 10:32:25 am »

@vhs

Looks to me you are coming from JPlay environment. For your info, licensed XXHE will do all Windows optimizations (probably more) without need of Process Lasso (PL), Audiophile Optimizer (AO) and Fidelizer Pro (FP). Simply press 'Minimize OS' and XXHE will do all that is needed for perfect PC audio reproduction. Server 2019 is variation of W10 where some services/processes are not activated. If I remember well, even Kernel Streaming is not started or even not installed at all.

Brgds,
George

Logged

XXHE 2.11 / W10 14393.0 / Asrock Extreme4-M, Xeon E5-2648L, 16GB DDR3 / NOS1, N.Pass F3, GR Research 'Venuette' OB
vhs
Audio Loudspeaker
*
Offline Offline

Posts: 5


View Profile
« Reply #6 on: July 02, 2021, 11:09:46 am »

@vhs

Looks to me you are coming from JPlay environment. For your info, licensed XXHE will do all Windows optimizations (probably more) without need of Process Lasso (PL), Audiophile Optimizer (AO) and Fidelizer Pro (FP). Simply press 'Minimize OS' and XXHE will do all that is needed for perfect PC audio reproduction. Server 2019 is variation of W10 where some services/processes are not activated. If I remember well, even Kernel Streaming is not started or even not installed at all.

Brgds,

George



Thx George

I used HQP and Jriver in WS2019 Core mode with AO3 & PL.

Currently I am auditing XXHighEnd, IMHO, it is better than HQP (with or without upsampling) and Jriver......

I am going to get the license of XXHighEnd within a couple of days.....

Cheers
Logged
PeterSt
Administrator
High Grade Audiophile
*****
Offline Offline

Posts: 15844



View Profile Email
« Reply #7 on: July 02, 2021, 06:25:23 pm »


Quote
If I remember well, even Kernel Streaming is not started or even not installed at all.

Hi there George - thank you.
Kernel streaming surely is installed. Without that no sound.
You probably were thinking of WASAPI.

Kind regards,
Peter
Logged

For the Stealth III LPS PC :
W10-14393.0 - Januari 24, 2021 (2.11)
XXHighEnd Mach III Stealth LPS PC -> Xeon Scalable 14/28 core with Hyperthreading On (set to 14/28 cores in BIOS and set to 10/20 cores via Boot Menu) @~660MHz, 48GB, Windows 10 Pro 64 bit build 14393.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/*0*/*0*/*0*/ Q1Factor = 1 / Dev.Buffer = 4096 / ClockRes = 15ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = 20.69  (max 20.69) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / Stop Desktop, Remaining, WASAPI and W10 services / Use Remote Desktop / Keep LAN - Not Persist / WallPaper On / OSD Off (!) / Running Time Off / Minimize OS / XTweaks : Balanced Load = *68* / Nervous Rate = 10 / Cool when Idle = n.a / Provide Stable Power = *1* / Utilize Cores always = 1 / Time Performance Index = Optimal / Time Stability = Stable / Custom Filtering *Low* (16x) / Always Clear Proxy before Playback = On -> USB3 from MoBo -> Lush^3
A: W-Y-R-G, B: W-Y-R* USB 1m00 -> Phisolator 24/768 Phasure NOS1a/G3 75B (BNC Out) async USB DAC, Driver v1.0.4b (16ms) -> B'ASS Current Amplifier -> Blaxius*^2.5* A:B-G, B:B-G Interlink -> Orelo MKII Active Open Baffle Horn Speakers. ET^2 Ethernet from Mach III to Music Server PC (RDC Control).
Removed Switching Supplies from everywhere (also from the PC).

For a general PC :
W10-10586.0 - May 2016 (2.05+)
*XXHighEnd PC -> I7 3930k with Hyperthreading On (12 cores)* @~500MHz, 16GB, Windows 10 Pro 64 bit build 10586.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/1/1/1 / Q1Factor = 1 / Dev.Buffer = 4096 / ClockRes = 1ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = 0.10  (max 60) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / All Services Off / Keep LAN - Not Persist / WallPaper On / OSD On / Running Time Off / Minimize OS / XTweaks : Balanced Load = *43* / Nervous Rate = 1 / Cool when Idle = 1 / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = *Optimal* / Time Stability = *Stable* / Custom Filter *Low* 705600 / -> USB3 *from MoBo* -> Clairixa USB 15cm -> Intona Isolator -> Clairixa USB 1m80 -> 24/768 Phasure NOS1a 75B (BNC Out) async USB DAC, Driver v1.0.4b (4ms) -> Blaxius BNC interlink *-> B'ASS Current Amplifier /w Level4 -> Blaxius Interlink* -> Orelo MKII Active Open Baffle Horn Speakers.
Removed Switching Supplies from everywhere.

Global Moderator
nik.d
Audio Loudspeaker
*
Offline Offline

Posts: 170


View Profile
« Reply #8 on: July 02, 2021, 09:00:00 pm »

Hi Peter,
No, it was problem with KS on WServer 2019 Core mode installation however it seems to be one of options in Audiophile Optimizer: 'to install Kernel Streaming and Media Player Support or not'. Never tried AO myself but read abt KS problem on another forum smile. Sure, without KS @vhs would not have sound at all smile

Logged

XXHE 2.11 / W10 14393.0 / Asrock Extreme4-M, Xeon E5-2648L, 16GB DDR3 / NOS1, N.Pass F3, GR Research 'Venuette' OB
vhs
Audio Loudspeaker
*
Offline Offline

Posts: 5


View Profile
« Reply #9 on: July 03, 2021, 08:09:11 am »

Hi Peter,
No, it was problem with KS on WServer 2019 Core mode installation however it seems to be one of options in Audiophile Optimizer: 'to install Kernel Streaming and Media Player Support or not'. Never tried AO myself but read abt KS problem on another forum smile. Sure, without KS @vhs would not have sound at all smile



Hi George,

Yes.. there is an option in AO to install KS in ws2019 core mode....... but I choose not to install.....I am using dCS ASIO as output....for Jriver and HQP

btw, I activated XXHighEnd last nite...and thank you so much for Peter's prompt response.....

XXHighEnd is the best music software in Windows environment I have ever used so far....


Cheers
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1 RC2 | SMF © 2001-2005, Lewis Media Valid XHTML 1.0! Valid CSS!
Page created in 0.085 seconds with 19 queries.