XXHighEnd - The Ultra HighEnd Audio Player
April 23, 2024, 09:46:25 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: August 6, 2017 : Phasure Webshop open ! Go to the Shop
Search current board structure only !!  
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: Host Process for Windows Services stopped working  (Read 7886 times)
0 Members and 0 Guests are viewing this topic.
arvind
Audio Enthusiast
**
Offline Offline

Posts: 529


View Profile
« on: August 26, 2009, 09:30:53 am »

Hi Peter,

When I start XXHE, a window opens stating "Host Process for Widows Services stopped working & was closed". Is this normal?

Arvind
Logged

W10-14393.0 RAM OS / Mach III LPS 14/28/XXHE 2.11/Engine#4/Adaptive Mode/16x /Custom Filter/Q1= 14/0/0/0 xQ1=1/Device Buffer:4096/Invert Phase=On/Minimise OS/PE=off/Unattended/Stop All Services/SFS=20.69/20.69(max)/ClockRes= 15ms/Straight Contiguous/Music on HDD/Lush^3 USB cable A:W-Y-R-G; B:W-Y-R/Phasure NOS 1a/75b/G3 USB DAC. > Blaxius*^2.5 A:B-G, B:B-G Interlink. Orelo MK II active speakers. ET^3 between Mach III & music server. Driver version 1.04/Driver Buffer 16ms. OSD text = Off
PeterSt
Administrator
High Grade Audiophile
*****
Offline Offline

Posts: 16837



View Profile Email
« Reply #1 on: August 26, 2009, 09:54:30 am »

Strangely enough : yes, that is normal. It is even good.

Let me first point at this topic : How I tweaked my Vista virtually dead which you mat have seen aleady. When you have performed everything in there (you can stick with the first dozen or so posts by myself, and the remainder is merely finetuning of other stuff not related to this subject) ... you will see that it doesn't happen anymore, or at least doesn't happen as often anymore. So what is going on ?

XXHighEnd (or actually XXEngine3) is surging so much resources to itself, that Windows Services don't get them anymore, and shut down. Now, the fun is, that these are the exact services you don't need for audio playback. A first will be the printer spooler.

What it all comes down to, is when you shut down those sevrices yourself, you won't see the messages anymore, obviously.

I must emphasize that even after performing the things in the link I referred to, there are still some left, because the ovjective of that topic was quite another : eliminate unnecessary disk I/O (and not eliminate all irrelevant services).
To capture all that may shut down automatically is a matter of finding out which they are, which is not always the most easy. But when time permits I'll find them. Also note that I don't have the approach of shutting all down except for what you may need, so, I work the other way around : shut everything down which bothers (theoretically). And this is certainly not all.

Btw and for fun, a few of them are shut down dynamically by XXHighEnd, but you have to tell first that you want that (Settings Area). Now, leave that on, and you will find that within a few hours (or even minutes) Vista does it for you (this is about Aero and all).

Lastly, I said "it is good" because everything which shuts down automatically, improves sound quality when not active. So, a nice dynamic feature by itself, but I don't think the creators of Vista are aware of this. nea

Peter
Logged

For the Stealth III LPS PC :
W10-14393.0 - July 17, 2021 (2.11)
XXHighEnd Mach III Stealth LPS PC -> Xeon Scalable 14/28 core with Hyperthreading On (set to 14/28 cores in BIOS and set to 10/20 cores via Boot Menu) @~660MHz, 48GB, Windows 10 Pro 64 bit build 14393.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/0/0/*1*/ Q1Factor = *4* / Dev.Buffer = 4096 / ClockRes = *10ms* / Memory = Straight Contiguous / Include Garbage Collect / SFS = *10.13*  (max 10.13) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / Stop Desktop, Remaining, WASAPI and W10 services / Use Remote Desktop / Keep LAN - Not Persist / WallPaper On / OSD Off (!) / Running Time Off / Minimize OS / XTweaks : Balanced Load = *62* / Nervous Rate = *1* / Cool when Idle = n.a / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = Optimal / Time Stability = Stable / Custom Filtering *Low* (16x) / Always Clear Proxy before Playback = On -> USB3 from MoBo -> Lush^3
A: W-Y-R-G, B: *W-G* USB 1m00 -> Phisolator 24/768 Phasure NOS1a/G3 75B (BNC Out) async USB DAC, Driver v1.0.4b (16ms) -> B'ASS Current Amplifier -> Blaxius*^2.5* A:B-G, B:B-G Interlink -> Orelo MKII Active Open Baffle Horn Speakers. ET^2 Ethernet from Mach III to Music Server PC (RDC Control).
Removed Switching Supplies from everywhere (also from the PC).

For a general PC :
W10-10586.0 - May 2016 (2.05+)
*XXHighEnd PC -> I7 3930k with Hyperthreading On (12 cores)* @~500MHz, 16GB, Windows 10 Pro 64 bit build 10586.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/1/1/1 / Q1Factor = 1 / Dev.Buffer = 4096 / ClockRes = 1ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = 0.10  (max 60) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / All Services Off / Keep LAN - Not Persist / WallPaper On / OSD On / Running Time Off / Minimize OS / XTweaks : Balanced Load = *43* / Nervous Rate = 1 / Cool when Idle = 1 / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = *Optimal* / Time Stability = *Stable* / Custom Filter *Low* 705600 / -> USB3 *from MoBo* -> Clairixa USB 15cm -> Intona Isolator -> Clairixa USB 1m80 -> 24/768 Phasure NOS1a 75B (BNC Out) async USB DAC, Driver v1.0.4b (4ms) -> Blaxius BNC interlink *-> B'ASS Current Amplifier /w Level4 -> Blaxius Interlink* -> Orelo MKII Active Open Baffle Horn Speakers.
Removed Switching Supplies from everywhere.

Global Moderator
LydMekk
Audio Loudspeaker
*
Offline Offline

Posts: 169



View Profile
« Reply #2 on: August 28, 2009, 06:11:15 am »

Isnt't it possible to make the program not aggrevate these HOST messages? I've found that turning off processor scheme and set the thread priorities to Nothing helps somewhat, but dosen't cure the problem 100%.

This is one of the things that HAS to be removed as a problem if you ever is gonna sell this program on any market...

The stone age user interface is something to be remedied too, Peter... unhappy
Logged

Dedicated PC - E6850 @ 3.6G - 8GB - 7TB - W7-64 Ultimate - Q=14,0,0,0,0 Noinv DoubleON - Anti Image - Pros Scheme 3 - Player/ThreadPrio Realtime - Volume 0db - Lexicon MC-12B Pro/Pre/DACs - HighEnd 7.1 System - All formats supported. XX=0.9y-8c, attended and unattended(!). Creative XFi Elite Pro, DAC is 24/96 and 32 bits is ticked.
SeVeReD
Audio Enthusiast
**
Offline Offline

Posts: 599


View Profile WWW Email
« Reply #3 on: August 28, 2009, 06:57:22 am »

I disagree LydMekk.  I don't think Peter is competing with the winamps of the world running Milkdrop visualizers..
The goal is the best SQ ... and if that causes a bit of hassle,,,, amen.  Of couse, I do think http://www.phasure.com/index.php?topic=548.0 needs to be rewritten and consolidated to be a bit more user friendly/english/other languages, along with rewriting autohotkey tutorial, although I can figure it out, I know others have had probs...but I figure we're still in beta and Peter must be hopping busy.  So, someday, tutorials rewritten and consolidated into one place... I have a gut feeling that we'll be moving to W7 soon, so might as well wait and write stuff up for that one.  I also think people should be told to dedicate their machines to XXHE, but that's just me too....

You really don't have to do anything to Vista to get XXHE working though,,, just tell people not to freak when host services pop up as stopped and to click OK.  I think that the biggest thing is someday doing a write up that's easy to follow, so people don't have to hunt through threads... for those of us who know where to look, not to hard...maybe have a stickied thread that links to all the tweaking stuff for now.

Oh well, maybe I've been away from other players for too long to understand "stone age user interface", But XXHE does everything I've wanted a top SQ player to do ... but I'm a 'put on an album and listen to it' person.  Probably why Peter hardly ever hears from me about 'bugs'... unless it's something about CUE files heh.
Logged

0.9z-8-3a WAV/CUE files on HDDs via MB FW400>; Win7 pro ttp://www.phasure.com/index.php?topic=352.msg4021#msg4021); [XXHighEnd player  Qs 7, 0, 0, 0, 0; eng 4; adaptive; scheme#3; player priority low; thread priority realtime; clock res 5ms: SFS 420 Wink dac is 24/192 w/32bits; Play Unattended; Stop Services ticked; Wallpaper & Show Back ticked - Mirror Image unticked; Start Engine unticked;garbage collect ticked; copy files to XX-drive; *quad arc prediction upsampling*: straight contiguous:>PCI FW800 card>Fireface 800 DAC [latency 2048 samples for 176.4]; usb/ethernet/mb audio shut off @ MB
Calibrator
Audio Enthusiast
**
Offline Offline

Posts: 556

Certified tweakaholic


View Profile
« Reply #4 on: August 28, 2009, 08:43:57 am »

... but I'm a 'put on an album and listen to it' person. 

I reckon I'm in that category also. If I wanted a jukebox interface I would be looking else where, but I like to sit down and generally enjoy an album from start to finish in the order the artist had, in most cases I presume, spent considerable time thinking how best to present their art. 

The interface may not have all the bells and whistles some others do, but it's essential functionality is intact, and only takes a little effort to find your way around the basics. There is more power lurking behind those context menu's though and I'll admit I even don't use them all .. haha

Once the bugs from these 'y' versions have been sorted so we are at the stability that the last of the 'X' 's had, we can all sit back and enjoy the music more ... until Peter brings out the "Z" versions ... LOL

It's all about the SQ.

Cheers,

Russ
Logged

(Sep 26th 2012) (0.9z-7-4 )
Parameters (0.9z-7-4) ->Coming soon...
Parameters (0.9z-6-1) ->Same as for 0.9z-6
Parameters (0.9z-6) ->http://members.iinet.net.au/~calibrator/XXHE/XXHE_parms_(0.9z-6).jpg
Hardware: Asus P5Q, H2O cooled 3.6GHz C2D, 8GB ram, W7 Ult X64 (NO SP1), O/S plus Galleries on 2x(OCZ 60GB Vertex2) -> ESI Juli@ (v0.978 drivers @ 48 samples) -> coax SPDIF -> Integra DHC-9.9 -> Hafler XL600 -> SGR Audio S-series Octagons -> aural organs -> nucleus accumbens sounds good !

====================
Turntables .. how quaint bored
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1 RC2 | SMF © 2001-2005, Lewis Media Valid XHTML 1.0! Valid CSS!
Page created in 0.103 seconds with 20 queries.