XXHighEnd - The Ultra HighEnd Audio Player
September 26, 2022, 11:53:49 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: August 6, 2017 : Phasure Webshop open ! Go to the Shop
Search current board structure only !!  
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: 09y-5.03 reset background  (Read 3804 times)
0 Members and 0 Guests are viewing this topic.
JohanZ
Audio Enthusiast
**
Offline Offline

Posts: 579


View Profile Email
« on: January 31, 2010, 07:03:02 pm »

Hi Peter,

A cosmetic request.
I had the impression you implemented it before. When you give a stop command during playback, XX stops and the background of windows becomes visible when you minimize XX. When XX stops automaticaly after playing the last track, the background of XX remains visible. It needs an extra stop command to get the windows background back again. When i load a new record , i always see after the play command shortly the old wallpaper in the background. Is it possible to implement the background reset also when XX stops after finishing the last track?

Johan
Logged

XXHE Ver: 209/MSI Z87M, i7 4770K Hyperthreading On (8 cores) @ 1,2 GHz, 32GB, Windows 10-14393.0 from RAM / Engine#4 Adaptive Mode / Q1/-/3/4/5 = *30*/-/1/1/1 Q1Factor = *40* / Dev.Buffer = 4096 / ClockRes = 15 / Memory = Straight Contiguous / Include Garbage Collect / SFS = *20.19* (max 120) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = *Core3-5* / Not Switch Processors during Playback / UnAttended (Just Start) / All Services Off / WallPaper On/ No OSD / No Running Time / Minimize OS / XTweaks : *Use Settings* - *43,1, 1, 1, 1* / Time Performance Index = Optimal / Time Stability = Stable/ Octo Arc Prediction Upsampling / -> USB3 -> Clairixa-Itona-Clairixa ->24/768 PHASURE NOS1a-75B-G3 , Driver v1.0.4b (*16ms*) -> Blaxius BNC interconnects ->Audion Silver Knight 300B-> Speakers CornScala
PeterSt
Administrator
High Grade Audiophile
*****
Offline Offline

Posts: 16541



View Profile Email
« Reply #1 on: February 01, 2010, 11:35:10 am »

Hi Johan,

Well, I think I recall you *asked* that before. But, besides I forgot about it, there are some things which makes me leave it as it is;

First of all (and now you may be right it has worked before !) this is all so "fragile" (read : difficult to have it consistent for all situations), that for that reason I rather leave it as it is. Everybody for sure will recall how many changes were applied to it, while those changes actually were solutions to "bugs". This is not because I created it too fast or anything, but because indeed there are so many combinations possible. And before you know it, your icons are not there while you need them.

Secondly, I think it can be justified how it currently works. I mean, it is not much different from bringing up XX yourself during playback, at selecting a next album (never mind playing is still commencing). In your example, when XX is brought up automatically, it is not brought up to reset the environment, but merely to let you choose another album (etc.). Theoretically you won't be needing more for that than what you get currently. Well, coincidentally you do want to do something else, and then indeed it requires a click on Stop (or remove XX at all). This is not a big deal, I think.

The shortly being visible of the old wallpaper (from the previous album) as you explained it, is another matter, of which I have wondered where it comes from. I mean, I don't think I am doing that and it is Windows which digs it up, somehow. Anyway, *that* is something that should be solved, but please not by the means you described.

Btw, notice that in order to let it all go as it now goes (of which I think it is ok, see above) I must use some technical means to detect how the environment is at that moment. One of these means is "does XXEngine3 run or not ?". Now, the kind of nasty situation which is in order here, is that while XXEngine3 starts XXHighEnd, XXHighEnd sees that XXEngine3 is running (for a very short while). And thus it thinks sound is playing, and thus it behaves like when you bring it up yourself when playback really is going on.

I hope this is a little satisfactory for you ... Happy
Peter
Logged

For the Stealth III LPS PC :
W10-14393.0 - July 17, 2021 (2.11)
XXHighEnd Mach III Stealth LPS PC -> Xeon Scalable 14/28 core with Hyperthreading On (set to 14/28 cores in BIOS and set to 10/20 cores via Boot Menu) @~660MHz, 48GB, Windows 10 Pro 64 bit build 14393.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/0/0/*1*/ Q1Factor = *4* / Dev.Buffer = 4096 / ClockRes = *10ms* / Memory = Straight Contiguous / Include Garbage Collect / SFS = *10.13*  (max 10.13) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / Stop Desktop, Remaining, WASAPI and W10 services / Use Remote Desktop / Keep LAN - Not Persist / WallPaper On / OSD Off (!) / Running Time Off / Minimize OS / XTweaks : Balanced Load = *62* / Nervous Rate = *1* / Cool when Idle = n.a / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = Optimal / Time Stability = Stable / Custom Filtering *Low* (16x) / Always Clear Proxy before Playback = On -> USB3 from MoBo -> Lush^3
A: W-Y-R-G, B: *W-G* USB 1m00 -> Phisolator 24/768 Phasure NOS1a/G3 75B (BNC Out) async USB DAC, Driver v1.0.4b (16ms) -> B'ASS Current Amplifier -> Blaxius*^2.5* A:B-G, B:B-G Interlink -> Orelo MKII Active Open Baffle Horn Speakers. ET^2 Ethernet from Mach III to Music Server PC (RDC Control).
Removed Switching Supplies from everywhere (also from the PC).

For a general PC :
W10-10586.0 - May 2016 (2.05+)
*XXHighEnd PC -> I7 3930k with Hyperthreading On (12 cores)* @~500MHz, 16GB, Windows 10 Pro 64 bit build 10586.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/1/1/1 / Q1Factor = 1 / Dev.Buffer = 4096 / ClockRes = 1ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = 0.10  (max 60) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / All Services Off / Keep LAN - Not Persist / WallPaper On / OSD On / Running Time Off / Minimize OS / XTweaks : Balanced Load = *43* / Nervous Rate = 1 / Cool when Idle = 1 / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = *Optimal* / Time Stability = *Stable* / Custom Filter *Low* 705600 / -> USB3 *from MoBo* -> Clairixa USB 15cm -> Intona Isolator -> Clairixa USB 1m80 -> 24/768 Phasure NOS1a 75B (BNC Out) async USB DAC, Driver v1.0.4b (4ms) -> Blaxius BNC interlink *-> B'ASS Current Amplifier /w Level4 -> Blaxius Interlink* -> Orelo MKII Active Open Baffle Horn Speakers.
Removed Switching Supplies from everywhere.

Global Moderator
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1 RC2 | SMF © 2001-2005, Lewis Media Valid XHTML 1.0! Valid CSS!
Page created in 0.028 seconds with 19 queries.