XXHighEnd - The Ultra HighEnd Audio Player
December 12, 2017, 01:52:47 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: August 6, 2017 : Phasure Webshop open ! Go to the Shop
Search current board structure only !!  
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: Engine#4: Vista vs XP  (Read 3023 times)
0 Members and 0 Guests are viewing this topic.
ivo
Audio Enthusiast
**
Offline Offline

Posts: 246


Music lover


View Profile WWW
« on: February 09, 2010, 05:36:44 pm »

Hi Peter,

I cannot try engine#4 because there are no KS devices under "Device" menu on my system. I wanted to talk about other:
Up to the XX version prior KS introduction you claimed and we all followed the rule: use Vista and up as it is the best for audio from MS so far.  99.99% of XX users are able to play via WASAPI (engine#3), but not that many (incl.me) via KS (engine#4). Why? Probably because there is no such thing as KS in Vista? Happy So, it seems like to use engine#4 - there is a bigger driver dependency than with WASAPI. BTW, I think Peter, you should have named engine#4 not KS, but something like DAS - Direct Audio Streaming as you actually talk to HW somehow different.

So, finally my magic question would be: Suppose I have a soundcard which can be used with engine#4 in both XP and Vista. So, then does it still matter which OS I use in terms of SQ? Have anyone compared the above statement really? This is becoming actual for me, because in my Vista I cannot deploy engine#4, but hopefully can on my old XP box with AudioTrak Prodigy HD2 card. So, I wonder if I switch back to XP will I loose the XX's magic.

Thanks,

Ivo
Logged

Music on internal HDD in FLAC-->LatestXX in QAP + PeakExt Mode[KS,Adaptive,2048,Q1=14,xQ1=1,Sch3,Low,Realtime,15 ms, SFS 2-400, Straight, stop all, MinOS]-->Windows 7 Pro SP1 x64bit-->Intel i5 based laptop [8 GB RAM]-->JKDAC32(HiFace based USB-I2S-DAC)-->Denon PMA-1500AE-->JBL E90 3-way speakers
PeterSt
Administrator
High Grade Audiophile
*****
Offline Offline

Posts: 14667



View Profile
« Reply #1 on: February 09, 2010, 08:46:14 pm »

Hey Ivo,

Quote
BTW, I think Peter, you should have named engine#4 not KS, but something like DAS - Direct Audio Streaming as you actually talk to HW somehow different.

Haha, I really love this ! I mean, I have been thinking about this much myself, but in the end didn't think it could be justified.

Allright, first off all notice that I started this little (heat) project because I wanted support for XP. And since I don't like ASIO (not available to everybody anyway) and wanted "bity perfect" output, this was the logical option. Next I couldn't help it much that it possibly superseeds WASAPI, although I of course did my best right from the start to let KS (under XP) not sound like Foobar etc.

KS still exists in Vista, although MS told it is emulated (just not true). But, MS wants to get rid of it ("so please driver developers, don't support it !" blahblah).

Quote
So, it seems like to use engine#4 - there is a bigger driver dependency than with WASAPI.

This is not only true, but also it needs different approaches in the software for different devices (as I found out). Worse, in XP it is again different, as I found out for at least USB. So, KS *is* just nothing worth much, and it is noticeable. ... Weren't it for it's SQ capabilities (as it now seems).

Quote
So, finally my magic question would be: Suppose I have a soundcard which can be used with engine#4 in both XP and Vista. So, then does it still matter which OS I use in terms of SQ?

I can't be sure at this moment, and it would need explicit comparing. Also, it is diccicult to estimate this from theories;
I guess you followed my remarks about Vista vs W7, and there you can see that "no changes to the audio stack" may result in a very different sound just because of stupid anticipations on the working of (in this case) Vista -> the task switching stuff). So I guess it will be a matter of trying.

Quote
This is becoming actual for me, because in my Vista I cannot deploy engine#4, but hopefully can on my old XP box with AudioTrak Prodigy HD2 card.

I can't be sure, but I think most drivers will run under Vista/W7 just the same BUT the Vista/W7 possibilities won't be exploited. Funny thing is : this is exactly what you don't need with KS. See the Juli@ example (which might be a coincidence).

Peter
Logged

For the Stealth LPS PC :
W10-14393.0 - November 13, 2017 (2.09)
XXHighEnd Mach II Stealth LPS PC -> Xeon E5 2640v4 with Hyperthreading On (20 cores) @~720MHz, 32GB, Windows 10 Pro 64 bit build 14393.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = *30*/-/*1*/*1*/*1*/ Q1Factor = *40* / Dev.Buffer = 4096 / ClockRes = *15ms* / Memory = Straight Contiguous / Include Garbage Collect / SFS = *0.90*  (max 120) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / Stop Desktop, Remaining, WASAPI and W10 services / Use Remote Desktop / Keep LAN - Not Persist / WallPaper On / *OSD Off* / Running Time Off / Minimize OS / XTweaks : Balanced Load = 43 / Nervous Rate = 100 / Cool when Idle = n.a / Provide Stable Power = 0 / Utilize Cores always = 1 / Time Performance Index = Optimal / Time Stability = Stable / *Custom Filtering Highest for 705600* / Always Clear Proxy before Playbck = On -> USB3 from MoBo -> Lush USB 1m00 -> Phisolator 24/768 Phasure NOS1a/G3 75B (BNC Out) async USB DAC, Driver v1.0.4b (*8ms*) -> B'ASS Current Amplifier -> Blaxius Interlink -> Orelo MKII Active Open Baffle Horn Speakers.
Removed Switching Supplies from everywhere (also from the PC).

For a general PC :
W10-10586.0 - May 2016 (2.05+)
*XXHighEnd PC -> I7 3930k with Hyperthreading On (12 cores)* @~500MHz, 16GB, Windows 10 Pro 64 bit build 10586.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/1/1/1 / Q1Factor = 1 / Dev.Buffer = 4096 / ClockRes = 1ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = 0.10  (max 60) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / All Services Off / Keep LAN - Not Persist / WallPaper On / OSD On / Running Time Off / Minimize OS / XTweaks : Balanced Load = *43* / Nervous Rate = 1 / Cool when Idle = 1 / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = *Optimal* / Time Stability = *Stable* / Custom Filter *Low* 705600 / -> USB3 *from MoBo* -> Clairixa USB 15cm -> Intona Isolator -> Clairixa USB 1m80 -> 24/768 Phasure NOS1a 75B (BNC Out) async USB DAC, Driver v1.0.4b (4ms) -> Blaxius BNC interlink *-> B'ASS Current Amplifier /w Level4 -> Blaxius Interlink* -> Orelo MKII Active Open Baffle Horn Speakers.
Removed Switching Supplies from everywhere.

Global Moderator
ivo
Audio Enthusiast
**
Offline Offline

Posts: 246


Music lover


View Profile WWW
« Reply #2 on: February 10, 2010, 12:35:09 am »

Peter,

I tried latest XX on my XP box and it works! There is KS: device and it plays OK even in QAP mode. So, that is shame that it does not on my laptop unhappy. Hope that someday KS of XX will work there, but less likely I guess.

Ivo
Logged

Music on internal HDD in FLAC-->LatestXX in QAP + PeakExt Mode[KS,Adaptive,2048,Q1=14,xQ1=1,Sch3,Low,Realtime,15 ms, SFS 2-400, Straight, stop all, MinOS]-->Windows 7 Pro SP1 x64bit-->Intel i5 based laptop [8 GB RAM]-->JKDAC32(HiFace based USB-I2S-DAC)-->Denon PMA-1500AE-->JBL E90 3-way speakers
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1 RC2 | SMF © 2001-2005, Lewis Media Valid XHTML 1.0! Valid CSS!
Page created in 0.445 seconds with 19 queries.