XXHighEnd - The Ultra HighEnd Audio Player
April 15, 2024, 08:18:59 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: August 6, 2017 : Phasure Webshop open ! Go to the Shop
Search current board structure only !!  
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: 0.9z52 Stops Playback with "End of Track" Message  (Read 8061 times)
0 Members and 0 Guests are viewing this topic.
Flecko
Audio Enthusiast
**
Offline Offline

Posts: 474


View Profile
« on: June 16, 2011, 01:07:50 am »

Hi Peter,
I have some problems with the new version of xx. It occurs quite often that the playback stops, with the error message "End of Track". If I click ok, the track starts again from an earlier position.
This seems to happen especially when I start windows 7 in debug mode. In this mode, most services are shut down and the biggest advantage for me is, that the hard drive makes no "sensless" noises. Also, I can use much bigger sfs and can start more tracks before the sfs error message "make smaler sfs..." appears.
Maybe there is an easys explaination why and a way how it could be solved.
Greetings Adrian
Logged

Software: Windows7 Ultimatex64SP1 | XXHighend 9z9b
Hardware: | Gigabyte X79-UD3 | i7-3820 | 16 GB DDR3 | OS on 128 GB Samsung SSD 830  | Music on 2TB WD Caviar Green | Seasonic X-660

XXHE Settings: | Engine 4 | Adaptive | Buffer=1024 | Q12345=[14,0,0,0,0] | xQ1=1 | Q5=3 | Scheme=3 | Mixed Contiguous with SFS=12 | 176.4kHz32bit | ArcPred + Peakextend | Clock=1ms |
Flecko
Audio Enthusiast
**
Offline Offline

Posts: 474


View Profile
« Reply #1 on: June 16, 2011, 01:32:21 am »

This message shows also in the normal mode as I experienced. But it seems to happen not as often as in debug mode.
Logged

Software: Windows7 Ultimatex64SP1 | XXHighend 9z9b
Hardware: | Gigabyte X79-UD3 | i7-3820 | 16 GB DDR3 | OS on 128 GB Samsung SSD 830  | Music on 2TB WD Caviar Green | Seasonic X-660

XXHE Settings: | Engine 4 | Adaptive | Buffer=1024 | Q12345=[14,0,0,0,0] | xQ1=1 | Q5=3 | Scheme=3 | Mixed Contiguous with SFS=12 | 176.4kHz32bit | ArcPred + Peakextend | Clock=1ms |
PeterSt
Administrator
High Grade Audiophile
*****
Offline Offline

Posts: 16837



View Profile Email
« Reply #2 on: June 16, 2011, 07:24:50 am »

I think I know what this is, not sure though ...

There will be services (and I don't know which one or ones) which take care of cacheing or more generally - speed up things related to disk I/O. When this service is not running, for sure it can happen that a file has been deleted, but the "space" is not freed yet. This really can take 30 seconds to my experience (and is VERY annoying).
XX depends on these kind of things, so there it will go wrong.

I don't think this will happen with Unattended (which is far more decently operating anyway).

Btw, can it be so that you use AI filtering ? the other day I noticed that at least with A-B active it is very prone to the End of track thing.

If you have some news on this, let me know; then I will try to solve it.
Peter
Logged

For the Stealth III LPS PC :
W10-14393.0 - July 17, 2021 (2.11)
XXHighEnd Mach III Stealth LPS PC -> Xeon Scalable 14/28 core with Hyperthreading On (set to 14/28 cores in BIOS and set to 10/20 cores via Boot Menu) @~660MHz, 48GB, Windows 10 Pro 64 bit build 14393.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/0/0/*1*/ Q1Factor = *4* / Dev.Buffer = 4096 / ClockRes = *10ms* / Memory = Straight Contiguous / Include Garbage Collect / SFS = *10.13*  (max 10.13) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / Stop Desktop, Remaining, WASAPI and W10 services / Use Remote Desktop / Keep LAN - Not Persist / WallPaper On / OSD Off (!) / Running Time Off / Minimize OS / XTweaks : Balanced Load = *62* / Nervous Rate = *1* / Cool when Idle = n.a / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = Optimal / Time Stability = Stable / Custom Filtering *Low* (16x) / Always Clear Proxy before Playback = On -> USB3 from MoBo -> Lush^3
A: W-Y-R-G, B: *W-G* USB 1m00 -> Phisolator 24/768 Phasure NOS1a/G3 75B (BNC Out) async USB DAC, Driver v1.0.4b (16ms) -> B'ASS Current Amplifier -> Blaxius*^2.5* A:B-G, B:B-G Interlink -> Orelo MKII Active Open Baffle Horn Speakers. ET^2 Ethernet from Mach III to Music Server PC (RDC Control).
Removed Switching Supplies from everywhere (also from the PC).

For a general PC :
W10-10586.0 - May 2016 (2.05+)
*XXHighEnd PC -> I7 3930k with Hyperthreading On (12 cores)* @~500MHz, 16GB, Windows 10 Pro 64 bit build 10586.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/1/1/1 / Q1Factor = 1 / Dev.Buffer = 4096 / ClockRes = 1ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = 0.10  (max 60) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / All Services Off / Keep LAN - Not Persist / WallPaper On / OSD On / Running Time Off / Minimize OS / XTweaks : Balanced Load = *43* / Nervous Rate = 1 / Cool when Idle = 1 / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = *Optimal* / Time Stability = *Stable* / Custom Filter *Low* 705600 / -> USB3 *from MoBo* -> Clairixa USB 15cm -> Intona Isolator -> Clairixa USB 1m80 -> 24/768 Phasure NOS1a 75B (BNC Out) async USB DAC, Driver v1.0.4b (4ms) -> Blaxius BNC interlink *-> B'ASS Current Amplifier /w Level4 -> Blaxius Interlink* -> Orelo MKII Active Open Baffle Horn Speakers.
Removed Switching Supplies from everywhere.

Global Moderator
Flecko
Audio Enthusiast
**
Offline Offline

Posts: 474


View Profile
« Reply #3 on: June 17, 2011, 12:48:28 am »

I don't use AI filtering. As it turned out, it happens also in normal Windows mode, where all services are running. I just had the problem twice in one track. I think this is related to the small sfs I use (10). Most of the time I use attended playback because the pc is not dedicaded to music only.
Logged

Software: Windows7 Ultimatex64SP1 | XXHighend 9z9b
Hardware: | Gigabyte X79-UD3 | i7-3820 | 16 GB DDR3 | OS on 128 GB Samsung SSD 830  | Music on 2TB WD Caviar Green | Seasonic X-660

XXHE Settings: | Engine 4 | Adaptive | Buffer=1024 | Q12345=[14,0,0,0,0] | xQ1=1 | Q5=3 | Scheme=3 | Mixed Contiguous with SFS=12 | 176.4kHz32bit | ArcPred + Peakextend | Clock=1ms |
PeterSt
Administrator
High Grade Audiophile
*****
Offline Offline

Posts: 16837



View Profile Email
« Reply #4 on: June 17, 2011, 05:32:03 am »

Quote
I think this is related to the small sfs I use (10).

Aha !
Yes, there is something in there which relates to that. But I'm afraid I can't to much about it. Also, it depends on the PC how much it bothers you.
But before we drift in the wrong direction, can't you set the SFS somewhat higher to, say, 40 - just play as usual but watch whether the pattern of this has changed ?


Quote
Most of the time I use attended playback because the pc is not dedicaded to music only.

I must honestly say that I tend to think that in such a case you shouldn't "complain". Your PC has only to be a little slow-ish to let the audio collapse. Well, with the limits we are using (and crossed).

But also see your other topic. There might be more going on. Quite confusing ... Happy
Logged

For the Stealth III LPS PC :
W10-14393.0 - July 17, 2021 (2.11)
XXHighEnd Mach III Stealth LPS PC -> Xeon Scalable 14/28 core with Hyperthreading On (set to 14/28 cores in BIOS and set to 10/20 cores via Boot Menu) @~660MHz, 48GB, Windows 10 Pro 64 bit build 14393.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/0/0/*1*/ Q1Factor = *4* / Dev.Buffer = 4096 / ClockRes = *10ms* / Memory = Straight Contiguous / Include Garbage Collect / SFS = *10.13*  (max 10.13) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / Stop Desktop, Remaining, WASAPI and W10 services / Use Remote Desktop / Keep LAN - Not Persist / WallPaper On / OSD Off (!) / Running Time Off / Minimize OS / XTweaks : Balanced Load = *62* / Nervous Rate = *1* / Cool when Idle = n.a / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = Optimal / Time Stability = Stable / Custom Filtering *Low* (16x) / Always Clear Proxy before Playback = On -> USB3 from MoBo -> Lush^3
A: W-Y-R-G, B: *W-G* USB 1m00 -> Phisolator 24/768 Phasure NOS1a/G3 75B (BNC Out) async USB DAC, Driver v1.0.4b (16ms) -> B'ASS Current Amplifier -> Blaxius*^2.5* A:B-G, B:B-G Interlink -> Orelo MKII Active Open Baffle Horn Speakers. ET^2 Ethernet from Mach III to Music Server PC (RDC Control).
Removed Switching Supplies from everywhere (also from the PC).

For a general PC :
W10-10586.0 - May 2016 (2.05+)
*XXHighEnd PC -> I7 3930k with Hyperthreading On (12 cores)* @~500MHz, 16GB, Windows 10 Pro 64 bit build 10586.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/1/1/1 / Q1Factor = 1 / Dev.Buffer = 4096 / ClockRes = 1ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = 0.10  (max 60) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / All Services Off / Keep LAN - Not Persist / WallPaper On / OSD On / Running Time Off / Minimize OS / XTweaks : Balanced Load = *43* / Nervous Rate = 1 / Cool when Idle = 1 / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = *Optimal* / Time Stability = *Stable* / Custom Filter *Low* 705600 / -> USB3 *from MoBo* -> Clairixa USB 15cm -> Intona Isolator -> Clairixa USB 1m80 -> 24/768 Phasure NOS1a 75B (BNC Out) async USB DAC, Driver v1.0.4b (4ms) -> Blaxius BNC interlink *-> B'ASS Current Amplifier /w Level4 -> Blaxius Interlink* -> Orelo MKII Active Open Baffle Horn Speakers.
Removed Switching Supplies from everywhere.

Global Moderator
Flecko
Audio Enthusiast
**
Offline Offline

Posts: 474


View Profile
« Reply #5 on: June 17, 2011, 04:07:05 pm »

Quote
Aha !
Yes, there is something in there which relates to that. But I'm afraid I can't to much about it. Also, it depends on the PC how much it bothers you.
But before we drift in the wrong direction, can't you set the SFS somewhat higher to, say, 40 - just play as usual but watch whether the pattern of this has changed ?
I can use 50 for mixed in normal mode and 110 in debug mode. It also occured with this higher settings. Maybe the sfs is not the only reason or was a misleading idea. There was one track, where directly as the track should start the error message poped up. The remarkable thing is, that I could repeat this 2 or 3 times. I started the track before, about 20 seconds before it's end. Then as the new track should play, the error appeared.

Quote
I must honestly say that I tend to think that in such a case you shouldn't "complain". Your PC has only to be a little slow-ish to let the audio collapse. Well, with the limits we are using (and crossed).

It also happens if the pc is doing "nothing". I would really like xx to be more stable. Then I could wholeheartly recommend it to friends. That is why I am complaining.
I look at it as a kind of science and how it is in science, there are always problems to solve. So I can understand, that there will always be some new problems. But a bug "free", stable version 1.0 of xx would realy be something! Even if it would not have the best sound possible at the moment.
If there are known border crossings that make xx unstable, wouldn't it be a good idea to have a kind of save mode for xx?
Logged

Software: Windows7 Ultimatex64SP1 | XXHighend 9z9b
Hardware: | Gigabyte X79-UD3 | i7-3820 | 16 GB DDR3 | OS on 128 GB Samsung SSD 830  | Music on 2TB WD Caviar Green | Seasonic X-660

XXHE Settings: | Engine 4 | Adaptive | Buffer=1024 | Q12345=[14,0,0,0,0] | xQ1=1 | Q5=3 | Scheme=3 | Mixed Contiguous with SFS=12 | 176.4kHz32bit | ArcPred + Peakextend | Clock=1ms |
PeterSt
Administrator
High Grade Audiophile
*****
Offline Offline

Posts: 16837



View Profile Email
« Reply #6 on: June 17, 2011, 05:05:38 pm »

Quote
If there are known border crossings that make xx unstable, wouldn't it be a good idea to have a kind of save mode for xx?

Yes. We call that "Unattended". Happy Happy
Logged

For the Stealth III LPS PC :
W10-14393.0 - July 17, 2021 (2.11)
XXHighEnd Mach III Stealth LPS PC -> Xeon Scalable 14/28 core with Hyperthreading On (set to 14/28 cores in BIOS and set to 10/20 cores via Boot Menu) @~660MHz, 48GB, Windows 10 Pro 64 bit build 14393.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/0/0/*1*/ Q1Factor = *4* / Dev.Buffer = 4096 / ClockRes = *10ms* / Memory = Straight Contiguous / Include Garbage Collect / SFS = *10.13*  (max 10.13) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / Stop Desktop, Remaining, WASAPI and W10 services / Use Remote Desktop / Keep LAN - Not Persist / WallPaper On / OSD Off (!) / Running Time Off / Minimize OS / XTweaks : Balanced Load = *62* / Nervous Rate = *1* / Cool when Idle = n.a / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = Optimal / Time Stability = Stable / Custom Filtering *Low* (16x) / Always Clear Proxy before Playback = On -> USB3 from MoBo -> Lush^3
A: W-Y-R-G, B: *W-G* USB 1m00 -> Phisolator 24/768 Phasure NOS1a/G3 75B (BNC Out) async USB DAC, Driver v1.0.4b (16ms) -> B'ASS Current Amplifier -> Blaxius*^2.5* A:B-G, B:B-G Interlink -> Orelo MKII Active Open Baffle Horn Speakers. ET^2 Ethernet from Mach III to Music Server PC (RDC Control).
Removed Switching Supplies from everywhere (also from the PC).

For a general PC :
W10-10586.0 - May 2016 (2.05+)
*XXHighEnd PC -> I7 3930k with Hyperthreading On (12 cores)* @~500MHz, 16GB, Windows 10 Pro 64 bit build 10586.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/1/1/1 / Q1Factor = 1 / Dev.Buffer = 4096 / ClockRes = 1ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = 0.10  (max 60) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / All Services Off / Keep LAN - Not Persist / WallPaper On / OSD On / Running Time Off / Minimize OS / XTweaks : Balanced Load = *43* / Nervous Rate = 1 / Cool when Idle = 1 / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = *Optimal* / Time Stability = *Stable* / Custom Filter *Low* 705600 / -> USB3 *from MoBo* -> Clairixa USB 15cm -> Intona Isolator -> Clairixa USB 1m80 -> 24/768 Phasure NOS1a 75B (BNC Out) async USB DAC, Driver v1.0.4b (4ms) -> Blaxius BNC interlink *-> B'ASS Current Amplifier /w Level4 -> Blaxius Interlink* -> Orelo MKII Active Open Baffle Horn Speakers.
Removed Switching Supplies from everywhere.

Global Moderator
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1 RC2 | SMF © 2001-2005, Lewis Media Valid XHTML 1.0! Valid CSS!
Page created in 0.053 seconds with 19 queries.