XXHighEnd - The Ultra HighEnd Audio Player
May 22, 2024, 12:45:10 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: August 6, 2017 : Phasure Webshop open ! Go to the Shop
Search current board structure only !!  
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: Ordering in Library (0.9l) and playlist  (Read 15557 times)
0 Members and 0 Guests are viewing this topic.
goon-heaven
Audio Loudspeaker
*
Offline Offline

Posts: 31



View Profile
« on: October 02, 2007, 08:48:58 am »

Hi Peter,

XP SP2

I have had problems previously with loading using the Library button: the Ordering in the Playlist, but found a workaround (i.e. select last track, shift click first track maintains alphabetic ordering loading into playlist.) This workaround still functions.

With 0.9l, in the library tab, I do not get alphabetic ordering.
Loading into the playlist using the Load button, I get ordering of tracks: 09, 10, 11, 12, 01, 02, 03, 04, 05, 06, 07, 08

I would include some screenshots but IrfanView capture gives me a nice shot of what is underneath XX? What screenshot capture software works on XX?

Best regards
Steve

Logged

7Ultimate 64bit on Patriot Torq 128 SSD, XX on 2Gb RAMDisk, music on NAS, i7-860 HT Off / Engine#4 Special Mode / Q1/2/3/4/5 = 1(32 samples)/0/0/0/0 Playerprio = Low / ThreadPrio = Real Time / Scheme = 3 Attended / FileSplit 1Gb / -> LynxTWO-B buffer size 32 -> EmmLabs DCC2 SE
PeterSt
Administrator
High Grade Audiophile
*****
Offline Offline

Posts: 16837



View Profile Email
« Reply #1 on: October 02, 2007, 09:19:27 am »

Hi Steve,

To answer your question about the screen-copy : SnagIt. It's not free, but worth the money for sure.
You could also try the printscreen button (shift-printscreen/ctrl-printscreen capures other areas of the screen) and then paste into a Word document and attatch that here.

I'll try to respond on the other things in a next post ... so in the mean time you can make the screencopies (I think they are important in order to understand better -> thinks look odd to me so far).

Peter
Logged

For the Stealth III LPS PC :
W10-14393.0 - July 17, 2021 (2.11)
XXHighEnd Mach III Stealth LPS PC -> Xeon Scalable 14/28 core with Hyperthreading On (set to 14/28 cores in BIOS and set to 10/20 cores via Boot Menu) @~660MHz, 48GB, Windows 10 Pro 64 bit build 14393.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/0/0/*1*/ Q1Factor = *4* / Dev.Buffer = 4096 / ClockRes = *10ms* / Memory = Straight Contiguous / Include Garbage Collect / SFS = *10.13*  (max 10.13) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / Stop Desktop, Remaining, WASAPI and W10 services / Use Remote Desktop / Keep LAN - Not Persist / WallPaper On / OSD Off (!) / Running Time Off / Minimize OS / XTweaks : Balanced Load = *62* / Nervous Rate = *1* / Cool when Idle = n.a / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = Optimal / Time Stability = Stable / Custom Filtering *Low* (16x) / Always Clear Proxy before Playback = On -> USB3 from MoBo -> Lush^3
A: W-Y-R-G, B: *W-G* USB 1m00 -> Phisolator 24/768 Phasure NOS1a/G3 75B (BNC Out) async USB DAC, Driver v1.0.4b (16ms) -> B'ASS Current Amplifier -> Blaxius*^2.5* A:B-G, B:B-G Interlink -> Orelo MKII Active Open Baffle Horn Speakers. ET^2 Ethernet from Mach III to Music Server PC (RDC Control).
Removed Switching Supplies from everywhere (also from the PC).

For a general PC :
W10-10586.0 - May 2016 (2.05+)
*XXHighEnd PC -> I7 3930k with Hyperthreading On (12 cores)* @~500MHz, 16GB, Windows 10 Pro 64 bit build 10586.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/1/1/1 / Q1Factor = 1 / Dev.Buffer = 4096 / ClockRes = 1ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = 0.10  (max 60) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / All Services Off / Keep LAN - Not Persist / WallPaper On / OSD On / Running Time Off / Minimize OS / XTweaks : Balanced Load = *43* / Nervous Rate = 1 / Cool when Idle = 1 / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = *Optimal* / Time Stability = *Stable* / Custom Filter *Low* 705600 / -> USB3 *from MoBo* -> Clairixa USB 15cm -> Intona Isolator -> Clairixa USB 1m80 -> 24/768 Phasure NOS1a 75B (BNC Out) async USB DAC, Driver v1.0.4b (4ms) -> Blaxius BNC interlink *-> B'ASS Current Amplifier /w Level4 -> Blaxius Interlink* -> Orelo MKII Active Open Baffle Horn Speakers.
Removed Switching Supplies from everywhere.

Global Moderator
PeterSt
Administrator
High Grade Audiophile
*****
Offline Offline

Posts: 16837



View Profile Email
« Reply #2 on: October 02, 2007, 09:52:57 am »

I have had problems previously with loading using the Library button: the Ordering in the Playlist, but found a workaround (i.e. select last track, shift click first track maintains alphabetic ordering loading into playlist.) This workaround still functions.

With 0.9l, in the library tab, I do not get alphabetic ordering.
Loading into the playlist using the Load button, I get ordering of tracks: 09, 10, 11, 12, 01, 02, 03, 04, 05, 06, 07, 08

For a better orientation here are some remarks :

The order you receive back from the Library button is something from the particular system part in the development environment, which I -at the time- could not solve within the time I gave myself for that. Possibly today I could ...
On the other hand, there's stuff in the Windows environment which actually always is there,  but not often noticed. For example, it might well be that when you copy files via Explorer, and you watch the sequence as how the files are dealt with, it's exactly the same. But do you care (or actually see it) at copying ? no.
Another thing for background info is that never mind the bunch of files you selected, the SEQUENCE you selected them, is maintained. This is "Windows" too, and I can imagine applications where this is useful. User-friendly is another matter, because once you selected all, you can't see the difference in the selected sequence anymore.

Both subjects in the above interact, and they interact wrongly. On the same matter you might have noticed long time ago that track 01 and 02 can be swapped in the Playlist (the sequence of the others just being allright). A long time I thought it was a (Windows) bug, until I found that it was just me and the way of clicking. I can't even tell right now what that was about, since I am now just used to doing it right.
Anyway, when I'd create an intermediate "array" and sort the things in there first, these "anomalies" would be gone. The "features" would be gone too then though.

Note that there is a difference between the Library Button and how that selects (in sequence) and how Explorer does it (and both is out of my control, unless I apply the intermediate as told). Btw, you really should use Explorer instead of the Library Button, but that's another matter.


Quote
I get ordering of tracks: 09, 10, 11, 12, 01, 02, 03, 04, 05, 06, 07, 08

Here, you received a result (after Search) of Albums including the Tracks, and the sequence is per Album (or Artist). Although I never tried it, here too you could have selected the range of 09, 10, 11, 12 first, and after that the range 01, 02, 03, 04, 05, 06, 07, 08 (I assume all are from the same Album). Remember, Windows can remember these things (and I only don't know whether that happens here; I just never tried it).
Also, it could well be that selecting from bottom to top (shift click etc.) presents all upside down in the Playlist (which would be correct then btw).

Now with the last assumption, don't get confused when the result is in Albums only (and not in Tracks); when you'd then select from bottom to top, the sequence of the Tracks within one Album would be ok, but the Albums themselves start with Z at the top (yeah, that would be ZZTop, haha).

Does this help you ?
Logged

For the Stealth III LPS PC :
W10-14393.0 - July 17, 2021 (2.11)
XXHighEnd Mach III Stealth LPS PC -> Xeon Scalable 14/28 core with Hyperthreading On (set to 14/28 cores in BIOS and set to 10/20 cores via Boot Menu) @~660MHz, 48GB, Windows 10 Pro 64 bit build 14393.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/0/0/*1*/ Q1Factor = *4* / Dev.Buffer = 4096 / ClockRes = *10ms* / Memory = Straight Contiguous / Include Garbage Collect / SFS = *10.13*  (max 10.13) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / Stop Desktop, Remaining, WASAPI and W10 services / Use Remote Desktop / Keep LAN - Not Persist / WallPaper On / OSD Off (!) / Running Time Off / Minimize OS / XTweaks : Balanced Load = *62* / Nervous Rate = *1* / Cool when Idle = n.a / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = Optimal / Time Stability = Stable / Custom Filtering *Low* (16x) / Always Clear Proxy before Playback = On -> USB3 from MoBo -> Lush^3
A: W-Y-R-G, B: *W-G* USB 1m00 -> Phisolator 24/768 Phasure NOS1a/G3 75B (BNC Out) async USB DAC, Driver v1.0.4b (16ms) -> B'ASS Current Amplifier -> Blaxius*^2.5* A:B-G, B:B-G Interlink -> Orelo MKII Active Open Baffle Horn Speakers. ET^2 Ethernet from Mach III to Music Server PC (RDC Control).
Removed Switching Supplies from everywhere (also from the PC).

For a general PC :
W10-10586.0 - May 2016 (2.05+)
*XXHighEnd PC -> I7 3930k with Hyperthreading On (12 cores)* @~500MHz, 16GB, Windows 10 Pro 64 bit build 10586.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/1/1/1 / Q1Factor = 1 / Dev.Buffer = 4096 / ClockRes = 1ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = 0.10  (max 60) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / All Services Off / Keep LAN - Not Persist / WallPaper On / OSD On / Running Time Off / Minimize OS / XTweaks : Balanced Load = *43* / Nervous Rate = 1 / Cool when Idle = 1 / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = *Optimal* / Time Stability = *Stable* / Custom Filter *Low* 705600 / -> USB3 *from MoBo* -> Clairixa USB 15cm -> Intona Isolator -> Clairixa USB 1m80 -> 24/768 Phasure NOS1a 75B (BNC Out) async USB DAC, Driver v1.0.4b (4ms) -> Blaxius BNC interlink *-> B'ASS Current Amplifier /w Level4 -> Blaxius Interlink* -> Orelo MKII Active Open Baffle Horn Speakers.
Removed Switching Supplies from everywhere.

Global Moderator
goon-heaven
Audio Loudspeaker
*
Offline Offline

Posts: 31



View Profile
« Reply #3 on: October 02, 2007, 12:18:07 pm »

Thanks Peter, attached is an image of the library tab, and another of the Playlist tab.
The library tab is from a blank search, and the playlist tab is from the Load button.

Does this clarify the issue?

Best regards
Steve


* XX-Library.jpg (39.07 KB, 636x477 - viewed 838 times.)

* XXPlaylist.jpg (35.91 KB, 639x478 - viewed 835 times.)
Logged

7Ultimate 64bit on Patriot Torq 128 SSD, XX on 2Gb RAMDisk, music on NAS, i7-860 HT Off / Engine#4 Special Mode / Q1/2/3/4/5 = 1(32 samples)/0/0/0/0 Playerprio = Low / ThreadPrio = Real Time / Scheme = 3 Attended / FileSplit 1Gb / -> LynxTWO-B buffer size 32 -> EmmLabs DCC2 SE
PeterSt
Administrator
High Grade Audiophile
*****
Offline Offline

Posts: 16837



View Profile Email
« Reply #4 on: October 02, 2007, 02:06:04 pm »

Uhohh ... I think I see what's going on ... that Ethernet disk / share, whatever it exactly is. This looks like a UDF formatted device (like a removeable harddisk could be) which won't sort ...
Look at your Albums, they are not sorted as well.

Btw, looking at this, you should (IMO) incorporate the "CDs" in the "Music Root" (Settings tab). It could even differ on the sorting ...
If this doesn't help, could you eleborate on the disk storage where this resides ? (a brand is good for me, or even a link to the manufacturer's site).
Logged

For the Stealth III LPS PC :
W10-14393.0 - July 17, 2021 (2.11)
XXHighEnd Mach III Stealth LPS PC -> Xeon Scalable 14/28 core with Hyperthreading On (set to 14/28 cores in BIOS and set to 10/20 cores via Boot Menu) @~660MHz, 48GB, Windows 10 Pro 64 bit build 14393.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/0/0/*1*/ Q1Factor = *4* / Dev.Buffer = 4096 / ClockRes = *10ms* / Memory = Straight Contiguous / Include Garbage Collect / SFS = *10.13*  (max 10.13) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / Stop Desktop, Remaining, WASAPI and W10 services / Use Remote Desktop / Keep LAN - Not Persist / WallPaper On / OSD Off (!) / Running Time Off / Minimize OS / XTweaks : Balanced Load = *62* / Nervous Rate = *1* / Cool when Idle = n.a / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = Optimal / Time Stability = Stable / Custom Filtering *Low* (16x) / Always Clear Proxy before Playback = On -> USB3 from MoBo -> Lush^3
A: W-Y-R-G, B: *W-G* USB 1m00 -> Phisolator 24/768 Phasure NOS1a/G3 75B (BNC Out) async USB DAC, Driver v1.0.4b (16ms) -> B'ASS Current Amplifier -> Blaxius*^2.5* A:B-G, B:B-G Interlink -> Orelo MKII Active Open Baffle Horn Speakers. ET^2 Ethernet from Mach III to Music Server PC (RDC Control).
Removed Switching Supplies from everywhere (also from the PC).

For a general PC :
W10-10586.0 - May 2016 (2.05+)
*XXHighEnd PC -> I7 3930k with Hyperthreading On (12 cores)* @~500MHz, 16GB, Windows 10 Pro 64 bit build 10586.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/1/1/1 / Q1Factor = 1 / Dev.Buffer = 4096 / ClockRes = 1ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = 0.10  (max 60) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / All Services Off / Keep LAN - Not Persist / WallPaper On / OSD On / Running Time Off / Minimize OS / XTweaks : Balanced Load = *43* / Nervous Rate = 1 / Cool when Idle = 1 / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = *Optimal* / Time Stability = *Stable* / Custom Filter *Low* 705600 / -> USB3 *from MoBo* -> Clairixa USB 15cm -> Intona Isolator -> Clairixa USB 1m80 -> 24/768 Phasure NOS1a 75B (BNC Out) async USB DAC, Driver v1.0.4b (4ms) -> Blaxius BNC interlink *-> B'ASS Current Amplifier /w Level4 -> Blaxius Interlink* -> Orelo MKII Active Open Baffle Horn Speakers.
Removed Switching Supplies from everywhere.

Global Moderator
goon-heaven
Audio Loudspeaker
*
Offline Offline

Posts: 31



View Profile
« Reply #5 on: October 02, 2007, 02:52:53 pm »

More Images...
1st is using Library Button on same ethernet drive(presumably a Windows function).
2nd is with CDs in the music root (though I have other directories at same level starting CD... i.e. CDs Breton where the genre is very different)
3rd is with a CDs directory in C: (set as music root) - this is sorted
4th is Playlist from there - this too is sorted

The ethernet drive is a 2TB Lacie BigDisk

My mother always said I was unkempt and unsorted...
Steve



* XX-LibraryButton.jpg (32.44 KB, 639x477 - viewed 868 times.)

* XX-RootofCDs.jpg (38.34 KB, 640x478 - viewed 795 times.)

* XX-RootofCdrive.jpg (40.08 KB, 641x478 - viewed 818 times.)

* XXRootofCdrive2.jpg (37.05 KB, 638x479 - viewed 821 times.)
Logged

7Ultimate 64bit on Patriot Torq 128 SSD, XX on 2Gb RAMDisk, music on NAS, i7-860 HT Off / Engine#4 Special Mode / Q1/2/3/4/5 = 1(32 samples)/0/0/0/0 Playerprio = Low / ThreadPrio = Real Time / Scheme = 3 Attended / FileSplit 1Gb / -> LynxTWO-B buffer size 32 -> EmmLabs DCC2 SE
PeterSt
Administrator
High Grade Audiophile
*****
Offline Offline

Posts: 16837



View Profile Email
« Reply #6 on: October 02, 2007, 05:55:08 pm »

It looks like you have a nice problem overthere ...

IIRC you can check the "base" ordering by means of a Dos-box and the DIR command. If it comes out sorted that's "Windows" controlling it. If it's not, then ... not. It would be out of my control and XX will work it out the same way.

BUT : I'm not 100% sure what's going on yet. So could you try the Dos-box thing ?
Try to compare it with something on your C: drive. That would be okay always (since NT4.0 / Windows2000 Happy) I think.
Logged

For the Stealth III LPS PC :
W10-14393.0 - July 17, 2021 (2.11)
XXHighEnd Mach III Stealth LPS PC -> Xeon Scalable 14/28 core with Hyperthreading On (set to 14/28 cores in BIOS and set to 10/20 cores via Boot Menu) @~660MHz, 48GB, Windows 10 Pro 64 bit build 14393.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/0/0/*1*/ Q1Factor = *4* / Dev.Buffer = 4096 / ClockRes = *10ms* / Memory = Straight Contiguous / Include Garbage Collect / SFS = *10.13*  (max 10.13) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / Stop Desktop, Remaining, WASAPI and W10 services / Use Remote Desktop / Keep LAN - Not Persist / WallPaper On / OSD Off (!) / Running Time Off / Minimize OS / XTweaks : Balanced Load = *62* / Nervous Rate = *1* / Cool when Idle = n.a / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = Optimal / Time Stability = Stable / Custom Filtering *Low* (16x) / Always Clear Proxy before Playback = On -> USB3 from MoBo -> Lush^3
A: W-Y-R-G, B: *W-G* USB 1m00 -> Phisolator 24/768 Phasure NOS1a/G3 75B (BNC Out) async USB DAC, Driver v1.0.4b (16ms) -> B'ASS Current Amplifier -> Blaxius*^2.5* A:B-G, B:B-G Interlink -> Orelo MKII Active Open Baffle Horn Speakers. ET^2 Ethernet from Mach III to Music Server PC (RDC Control).
Removed Switching Supplies from everywhere (also from the PC).

For a general PC :
W10-10586.0 - May 2016 (2.05+)
*XXHighEnd PC -> I7 3930k with Hyperthreading On (12 cores)* @~500MHz, 16GB, Windows 10 Pro 64 bit build 10586.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/1/1/1 / Q1Factor = 1 / Dev.Buffer = 4096 / ClockRes = 1ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = 0.10  (max 60) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / All Services Off / Keep LAN - Not Persist / WallPaper On / OSD On / Running Time Off / Minimize OS / XTweaks : Balanced Load = *43* / Nervous Rate = 1 / Cool when Idle = 1 / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = *Optimal* / Time Stability = *Stable* / Custom Filter *Low* 705600 / -> USB3 *from MoBo* -> Clairixa USB 15cm -> Intona Isolator -> Clairixa USB 1m80 -> 24/768 Phasure NOS1a 75B (BNC Out) async USB DAC, Driver v1.0.4b (4ms) -> Blaxius BNC interlink *-> B'ASS Current Amplifier /w Level4 -> Blaxius Interlink* -> Orelo MKII Active Open Baffle Horn Speakers.
Removed Switching Supplies from everywhere.

Global Moderator
goon-heaven
Audio Loudspeaker
*
Offline Offline

Posts: 31



View Profile
« Reply #7 on: October 02, 2007, 06:26:02 pm »

I do not have any Dos-Boxes - moved around too often to have any lying around.

For what its worth I recall having the same Library button track sort symptom/workaround.
Without trying to rub salt in, Foobar (which I used before moving to XX) keeps alphabetic ordering on tracks when selecting an album directory.
Logged

7Ultimate 64bit on Patriot Torq 128 SSD, XX on 2Gb RAMDisk, music on NAS, i7-860 HT Off / Engine#4 Special Mode / Q1/2/3/4/5 = 1(32 samples)/0/0/0/0 Playerprio = Low / ThreadPrio = Real Time / Scheme = 3 Attended / FileSplit 1Gb / -> LynxTWO-B buffer size 32 -> EmmLabs DCC2 SE
PeterSt
Administrator
High Grade Audiophile
*****
Offline Offline

Posts: 16837



View Profile Email
« Reply #8 on: October 02, 2007, 07:44:09 pm »

Uhmm ... a Dos-box is something like the black icon below ... (I couldn't tell whether you were serious no)

About Foobar, yes, but note that could be similar to my earlier remark about putting things in an array first and sort it there (myself). Note though that officially it wouldn't be the way (that way not being adaptive to future versions, or XP/Vista etc. not being compatible). But if it otherwise produces bugs which can't be overcome ...
Also note that this is kind of the problem when working "officially" (dot-net in XX' case). Look at Foobar ... it doesn't look much like "Windows" ... which is no drawback by itself, but tells me that it's all, say, unofficial (and the latter not being worth a penny really).


Anyway, look at the below Dos-box, and you see there what I talked about earlier; compare the sorting with the Explorer screen at the bottom;
That disk is "UDF formatted" and shows this behaviour. You could call this a bug by itself.
Now all you need to know further is that the various Windows functions (technical : like Dialogs) behave differently exactly on this matter. E.g. the Library function calls one of them, and the Library Area another. Explorer would be a third, although it should be similar to the Library Area.

Remember, I still did not say this is your problem; I'd need your Dos-box adventure for that ...  thankyou


* DosBox01.png (10.47 KB, 413x220 - viewed 781 times.)

* Sort01.png (16.62 KB, 672x343 - viewed 698 times.)

* Sort02.png (16.72 KB, 511x482 - viewed 807 times.)
Logged

For the Stealth III LPS PC :
W10-14393.0 - July 17, 2021 (2.11)
XXHighEnd Mach III Stealth LPS PC -> Xeon Scalable 14/28 core with Hyperthreading On (set to 14/28 cores in BIOS and set to 10/20 cores via Boot Menu) @~660MHz, 48GB, Windows 10 Pro 64 bit build 14393.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/0/0/*1*/ Q1Factor = *4* / Dev.Buffer = 4096 / ClockRes = *10ms* / Memory = Straight Contiguous / Include Garbage Collect / SFS = *10.13*  (max 10.13) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / Stop Desktop, Remaining, WASAPI and W10 services / Use Remote Desktop / Keep LAN - Not Persist / WallPaper On / OSD Off (!) / Running Time Off / Minimize OS / XTweaks : Balanced Load = *62* / Nervous Rate = *1* / Cool when Idle = n.a / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = Optimal / Time Stability = Stable / Custom Filtering *Low* (16x) / Always Clear Proxy before Playback = On -> USB3 from MoBo -> Lush^3
A: W-Y-R-G, B: *W-G* USB 1m00 -> Phisolator 24/768 Phasure NOS1a/G3 75B (BNC Out) async USB DAC, Driver v1.0.4b (16ms) -> B'ASS Current Amplifier -> Blaxius*^2.5* A:B-G, B:B-G Interlink -> Orelo MKII Active Open Baffle Horn Speakers. ET^2 Ethernet from Mach III to Music Server PC (RDC Control).
Removed Switching Supplies from everywhere (also from the PC).

For a general PC :
W10-10586.0 - May 2016 (2.05+)
*XXHighEnd PC -> I7 3930k with Hyperthreading On (12 cores)* @~500MHz, 16GB, Windows 10 Pro 64 bit build 10586.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/1/1/1 / Q1Factor = 1 / Dev.Buffer = 4096 / ClockRes = 1ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = 0.10  (max 60) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / All Services Off / Keep LAN - Not Persist / WallPaper On / OSD On / Running Time Off / Minimize OS / XTweaks : Balanced Load = *43* / Nervous Rate = 1 / Cool when Idle = 1 / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = *Optimal* / Time Stability = *Stable* / Custom Filter *Low* 705600 / -> USB3 *from MoBo* -> Clairixa USB 15cm -> Intona Isolator -> Clairixa USB 1m80 -> 24/768 Phasure NOS1a 75B (BNC Out) async USB DAC, Driver v1.0.4b (4ms) -> Blaxius BNC interlink *-> B'ASS Current Amplifier /w Level4 -> Blaxius Interlink* -> Orelo MKII Active Open Baffle Horn Speakers.
Removed Switching Supplies from everywhere.

Global Moderator
PeterSt
Administrator
High Grade Audiophile
*****
Offline Offline

Posts: 16837



View Profile Email
« Reply #9 on: October 02, 2007, 08:02:18 pm »

Btw, in order to prove the UDF formatted disk thing, below is similar, but now from a "normally" NTFS formatted disk.
What you see is that in the above the files are sorted by date/time of change (creation I'd say). This would be conform the UDF format which is the same principle as a CD is organized. Think of this : even a CDRom can be edited (as long as it's not officially closed). But what happens is that the TOC (table of contents) is overruled, all the foriginal files stay there but can't be found in the TOC anymore, and any new (or changed) files are physically added at the bottom. That's what the DIR command from Dos shows. Windows though can deal with it. But not everywhere ... (and this is for 100% sure; I know that from other software). Again, whether that's your culprit I can't tell yet.

You could look at the dates/times of the wrongly ordered files ...


* Sort03.png (15 KB, 669x337 - viewed 782 times.)
Logged

For the Stealth III LPS PC :
W10-14393.0 - July 17, 2021 (2.11)
XXHighEnd Mach III Stealth LPS PC -> Xeon Scalable 14/28 core with Hyperthreading On (set to 14/28 cores in BIOS and set to 10/20 cores via Boot Menu) @~660MHz, 48GB, Windows 10 Pro 64 bit build 14393.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/0/0/*1*/ Q1Factor = *4* / Dev.Buffer = 4096 / ClockRes = *10ms* / Memory = Straight Contiguous / Include Garbage Collect / SFS = *10.13*  (max 10.13) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / Stop Desktop, Remaining, WASAPI and W10 services / Use Remote Desktop / Keep LAN - Not Persist / WallPaper On / OSD Off (!) / Running Time Off / Minimize OS / XTweaks : Balanced Load = *62* / Nervous Rate = *1* / Cool when Idle = n.a / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = Optimal / Time Stability = Stable / Custom Filtering *Low* (16x) / Always Clear Proxy before Playback = On -> USB3 from MoBo -> Lush^3
A: W-Y-R-G, B: *W-G* USB 1m00 -> Phisolator 24/768 Phasure NOS1a/G3 75B (BNC Out) async USB DAC, Driver v1.0.4b (16ms) -> B'ASS Current Amplifier -> Blaxius*^2.5* A:B-G, B:B-G Interlink -> Orelo MKII Active Open Baffle Horn Speakers. ET^2 Ethernet from Mach III to Music Server PC (RDC Control).
Removed Switching Supplies from everywhere (also from the PC).

For a general PC :
W10-10586.0 - May 2016 (2.05+)
*XXHighEnd PC -> I7 3930k with Hyperthreading On (12 cores)* @~500MHz, 16GB, Windows 10 Pro 64 bit build 10586.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/1/1/1 / Q1Factor = 1 / Dev.Buffer = 4096 / ClockRes = 1ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = 0.10  (max 60) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / All Services Off / Keep LAN - Not Persist / WallPaper On / OSD On / Running Time Off / Minimize OS / XTweaks : Balanced Load = *43* / Nervous Rate = 1 / Cool when Idle = 1 / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = *Optimal* / Time Stability = *Stable* / Custom Filter *Low* 705600 / -> USB3 *from MoBo* -> Clairixa USB 15cm -> Intona Isolator -> Clairixa USB 1m80 -> 24/768 Phasure NOS1a 75B (BNC Out) async USB DAC, Driver v1.0.4b (4ms) -> Blaxius BNC interlink *-> B'ASS Current Amplifier /w Level4 -> Blaxius Interlink* -> Orelo MKII Active Open Baffle Horn Speakers.
Removed Switching Supplies from everywhere.

Global Moderator
goon-heaven
Audio Loudspeaker
*
Offline Offline

Posts: 31



View Profile
« Reply #10 on: October 03, 2007, 09:00:56 am »

Sorry - Mis-understood Dos-Box - not heard it called that before.

1st image is end of the DIR listing of mapped drive of the ethernet disk. The date/time appear to be up creek. I did a bulk copy after installing the disk. Since then I have added 7 CDs into that directory - the last 7 items on the DIR.

2nd image is DIR listing of tracks of a CD directory on the mapped drive. I rip to C: and then cut and paste in explorer.



* DIR OF MAPPED DRIVE.jpg (52.76 KB, 667x336 - viewed 769 times.)

* DIR OF TRACKS.jpg (40.61 KB, 669x336 - viewed 790 times.)
Logged

7Ultimate 64bit on Patriot Torq 128 SSD, XX on 2Gb RAMDisk, music on NAS, i7-860 HT Off / Engine#4 Special Mode / Q1/2/3/4/5 = 1(32 samples)/0/0/0/0 Playerprio = Low / ThreadPrio = Real Time / Scheme = 3 Attended / FileSplit 1Gb / -> LynxTWO-B buffer size 32 -> EmmLabs DCC2 SE
PeterSt
Administrator
High Grade Audiophile
*****
Offline Offline

Posts: 16837



View Profile Email
« Reply #11 on: October 03, 2007, 09:20:12 am »

rofl
sorry

and then cut and paste in explorer.

And that is were the track sequence got wrong (well, I bet). So you could have selected tracks 1-8 first, and then added 9-12 to the selection. Or the other way around.

Anyway ... it's always nice to see my guessings workout. Now up to solving it ...

Actually I was already thinking about it, and I think I know where the problem is / can be solved. This will be a very tough job and requires a re-setup of things. By itself this is no problem because the speed has to be improved anyway, but it's so complex that I wonder when I will have achieved it.
FYI : This is about the (nearly unavoidable) sorting procedures which are used internally (again, these are dot-net functions) which sort a first column ok, but all of the others upside down. Yep, very similar to how the Library button operates (as you told, also upside down). In this case it would mean that your albums will sort okay, but the tracks within them will be upside down.

I don't want to bother you with my problems, but just want to indicate that there's many bugs in system software, and it takes much (in fact wasted) time to avoid them.
Currently I avoided this upside down bug by NOT sorting ... which is now attacked by the UDF-wrong sequence bug.

Oh well ...

Thank you for presenting the data Steve.
Peter
Logged

For the Stealth III LPS PC :
W10-14393.0 - July 17, 2021 (2.11)
XXHighEnd Mach III Stealth LPS PC -> Xeon Scalable 14/28 core with Hyperthreading On (set to 14/28 cores in BIOS and set to 10/20 cores via Boot Menu) @~660MHz, 48GB, Windows 10 Pro 64 bit build 14393.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/0/0/*1*/ Q1Factor = *4* / Dev.Buffer = 4096 / ClockRes = *10ms* / Memory = Straight Contiguous / Include Garbage Collect / SFS = *10.13*  (max 10.13) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / Stop Desktop, Remaining, WASAPI and W10 services / Use Remote Desktop / Keep LAN - Not Persist / WallPaper On / OSD Off (!) / Running Time Off / Minimize OS / XTweaks : Balanced Load = *62* / Nervous Rate = *1* / Cool when Idle = n.a / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = Optimal / Time Stability = Stable / Custom Filtering *Low* (16x) / Always Clear Proxy before Playback = On -> USB3 from MoBo -> Lush^3
A: W-Y-R-G, B: *W-G* USB 1m00 -> Phisolator 24/768 Phasure NOS1a/G3 75B (BNC Out) async USB DAC, Driver v1.0.4b (16ms) -> B'ASS Current Amplifier -> Blaxius*^2.5* A:B-G, B:B-G Interlink -> Orelo MKII Active Open Baffle Horn Speakers. ET^2 Ethernet from Mach III to Music Server PC (RDC Control).
Removed Switching Supplies from everywhere (also from the PC).

For a general PC :
W10-10586.0 - May 2016 (2.05+)
*XXHighEnd PC -> I7 3930k with Hyperthreading On (12 cores)* @~500MHz, 16GB, Windows 10 Pro 64 bit build 10586.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/1/1/1 / Q1Factor = 1 / Dev.Buffer = 4096 / ClockRes = 1ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = 0.10  (max 60) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / All Services Off / Keep LAN - Not Persist / WallPaper On / OSD On / Running Time Off / Minimize OS / XTweaks : Balanced Load = *43* / Nervous Rate = 1 / Cool when Idle = 1 / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = *Optimal* / Time Stability = *Stable* / Custom Filter *Low* 705600 / -> USB3 *from MoBo* -> Clairixa USB 15cm -> Intona Isolator -> Clairixa USB 1m80 -> 24/768 Phasure NOS1a 75B (BNC Out) async USB DAC, Driver v1.0.4b (4ms) -> Blaxius BNC interlink *-> B'ASS Current Amplifier /w Level4 -> Blaxius Interlink* -> Orelo MKII Active Open Baffle Horn Speakers.
Removed Switching Supplies from everywhere.

Global Moderator
goon-heaven
Audio Loudspeaker
*
Offline Offline

Posts: 31



View Profile
« Reply #12 on: October 03, 2007, 11:06:44 am »

Thanks Peter - no panic - I have the workaround. Good luck with the dot-not work.
Logged

7Ultimate 64bit on Patriot Torq 128 SSD, XX on 2Gb RAMDisk, music on NAS, i7-860 HT Off / Engine#4 Special Mode / Q1/2/3/4/5 = 1(32 samples)/0/0/0/0 Playerprio = Low / ThreadPrio = Real Time / Scheme = 3 Attended / FileSplit 1Gb / -> LynxTWO-B buffer size 32 -> EmmLabs DCC2 SE
PeterSt
Administrator
High Grade Audiophile
*****
Offline Offline

Posts: 16837



View Profile Email
« Reply #13 on: January 24, 2008, 11:22:52 am »

Steve, it just slips to my mind that since a few versions ago this should be solved. But is it ? I can't test it myself since I don't have the problem.

Thanks,
Peter
Logged

For the Stealth III LPS PC :
W10-14393.0 - July 17, 2021 (2.11)
XXHighEnd Mach III Stealth LPS PC -> Xeon Scalable 14/28 core with Hyperthreading On (set to 14/28 cores in BIOS and set to 10/20 cores via Boot Menu) @~660MHz, 48GB, Windows 10 Pro 64 bit build 14393.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/0/0/*1*/ Q1Factor = *4* / Dev.Buffer = 4096 / ClockRes = *10ms* / Memory = Straight Contiguous / Include Garbage Collect / SFS = *10.13*  (max 10.13) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / Stop Desktop, Remaining, WASAPI and W10 services / Use Remote Desktop / Keep LAN - Not Persist / WallPaper On / OSD Off (!) / Running Time Off / Minimize OS / XTweaks : Balanced Load = *62* / Nervous Rate = *1* / Cool when Idle = n.a / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = Optimal / Time Stability = Stable / Custom Filtering *Low* (16x) / Always Clear Proxy before Playback = On -> USB3 from MoBo -> Lush^3
A: W-Y-R-G, B: *W-G* USB 1m00 -> Phisolator 24/768 Phasure NOS1a/G3 75B (BNC Out) async USB DAC, Driver v1.0.4b (16ms) -> B'ASS Current Amplifier -> Blaxius*^2.5* A:B-G, B:B-G Interlink -> Orelo MKII Active Open Baffle Horn Speakers. ET^2 Ethernet from Mach III to Music Server PC (RDC Control).
Removed Switching Supplies from everywhere (also from the PC).

For a general PC :
W10-10586.0 - May 2016 (2.05+)
*XXHighEnd PC -> I7 3930k with Hyperthreading On (12 cores)* @~500MHz, 16GB, Windows 10 Pro 64 bit build 10586.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/1/1/1 / Q1Factor = 1 / Dev.Buffer = 4096 / ClockRes = 1ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = 0.10  (max 60) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / All Services Off / Keep LAN - Not Persist / WallPaper On / OSD On / Running Time Off / Minimize OS / XTweaks : Balanced Load = *43* / Nervous Rate = 1 / Cool when Idle = 1 / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = *Optimal* / Time Stability = *Stable* / Custom Filter *Low* 705600 / -> USB3 *from MoBo* -> Clairixa USB 15cm -> Intona Isolator -> Clairixa USB 1m80 -> 24/768 Phasure NOS1a 75B (BNC Out) async USB DAC, Driver v1.0.4b (4ms) -> Blaxius BNC interlink *-> B'ASS Current Amplifier /w Level4 -> Blaxius Interlink* -> Orelo MKII Active Open Baffle Horn Speakers.
Removed Switching Supplies from everywhere.

Global Moderator
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1 RC2 | SMF © 2001-2005, Lewis Media Valid XHTML 1.0! Valid CSS!
Page created in 0.029 seconds with 19 queries.