XXHighEnd - The Ultra HighEnd Audio Player
May 27, 2024, 08:48:21 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: August 6, 2017 : Phasure Webshop open ! Go to the Shop
Search current board structure only !!  
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: Sound device changes unintentionally  (Read 6898 times)
0 Members and 0 Guests are viewing this topic.
arvind
Audio Enthusiast
**
Offline Offline

Posts: 529


View Profile
« on: January 16, 2014, 09:40:50 am »

Hi Peter,

Since 1.186a, I have had the following problem:
The selected device(in settings) is the KS NOS1 but many times if i change tracks or change volume (with hotkeys) the selected device shifts to Primary Sound Driver or other devices connected to the PC.

I think this is problem is connected more with my reducing the CPU clock speed rather than the XXHE version. Is this a correct assumption?

Regards,

Arvind
« Last Edit: January 16, 2014, 10:19:57 am by PeterSt » Logged

W10-14393.0 RAM OS / Mach III LPS 14/28/XXHE 2.11/Engine#4/Adaptive Mode/16x /Custom Filter/Q1= 14/0/0/0 xQ1=1/Device Buffer:4096/Invert Phase=On/Minimise OS/PE=off/Unattended/Stop All Services/SFS=20.69/20.69(max)/ClockRes= 15ms/Straight Contiguous/Music on HDD/Lush^3 USB cable A:W-Y-R-G; B:W-Y-R/Phasure NOS 1a/75b/G3 USB DAC. > Blaxius*^2.5 A:B-G, B:B-G Interlink. Orelo MK II active speakers. ET^3 between Mach III & music server. Driver version 1.04/Driver Buffer 16ms. OSD text = Off
christoffe
Audio Addict
***
Offline Offline

Posts: 762


View Profile Email
« Reply #1 on: January 16, 2014, 10:36:27 am »

Hi Peter,

Since 1.186a, I have had the following problem:
The selected device(in settings) is the KS NOS1 but many times if i change tracks or change volume (with hotkeys) the selected device shifts to Primary Sound Driver or other devices connected to the PC.

I think this is problem is connected more with my reducing the CPU clock speed rather than the XXHE version. Is this a correct assumption?

Regards,

Arvind

Same problem 2 times since I changed Q5 from 0 to 1.

NOS1 DC offset readings was with Q5=0  - 00,1/0,00 after PC normal shut downs.
and with Q5=1 after every 4th PC shut down DC offset shows appr. 26.5/26.0 and I have to restart the NOS1.
My sig is up to date.

The sound with Q5 =1 is amazing.

Joachim
Logged
PeterSt
Administrator
High Grade Audiophile
*****
Offline Offline

Posts: 16837



View Profile Email
« Reply #2 on: January 16, 2014, 11:11:44 am »

Hi you both,

I can recognize that this can happen for some (not the DC Offset thing, so Joachim, please start a topic for that if you want), but I am not sure how to solve it from the software side. This will help though :

Assumed you are in Minimized OS and you won't be using orther sound devices anyway, disable all the other Kernel Streaming (KS:) devices. Or just "all the others" when you leave WASAPI services on. So now only your sound device you use for playback remains (the NOS1 for your both cases) and now the system will not be able to select another because of timing issues.
Also, it is just better for SQ when the other sound devices are disabled.

Disable them through the loudsepaker icon in the Taskbar Tray.

I told it elsewhere (could be email) : I don't even notice such issues because I *have* disabled the other devices always. However, I do see a message about it sometimes, but click that away and there's no problem. Obviously this message should not appear during a volume change, because then your volume change won't happen. But *that* I never saw. At just bringing up XXHighEnd (playback going on or not) such a message can appear sometimes. But, let me know when it happens more than that it does not happen, because then it is too inconvenient and something should change. I *can* change it, but the startup of XXHighEnd will take longer (close to twice as long and how it was with 0.9z-9b (not beyond it like 0.9z-9c and further).

Regards,
Peter
Logged

For the Stealth III LPS PC :
W10-14393.0 - July 17, 2021 (2.11)
XXHighEnd Mach III Stealth LPS PC -> Xeon Scalable 14/28 core with Hyperthreading On (set to 14/28 cores in BIOS and set to 10/20 cores via Boot Menu) @~660MHz, 48GB, Windows 10 Pro 64 bit build 14393.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/0/0/*1*/ Q1Factor = *4* / Dev.Buffer = 4096 / ClockRes = *10ms* / Memory = Straight Contiguous / Include Garbage Collect / SFS = *10.13*  (max 10.13) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / Stop Desktop, Remaining, WASAPI and W10 services / Use Remote Desktop / Keep LAN - Not Persist / WallPaper On / OSD Off (!) / Running Time Off / Minimize OS / XTweaks : Balanced Load = *62* / Nervous Rate = *1* / Cool when Idle = n.a / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = Optimal / Time Stability = Stable / Custom Filtering *Low* (16x) / Always Clear Proxy before Playback = On -> USB3 from MoBo -> Lush^3
A: W-Y-R-G, B: *W-G* USB 1m00 -> Phisolator 24/768 Phasure NOS1a/G3 75B (BNC Out) async USB DAC, Driver v1.0.4b (16ms) -> B'ASS Current Amplifier -> Blaxius*^2.5* A:B-G, B:B-G Interlink -> Orelo MKII Active Open Baffle Horn Speakers. ET^2 Ethernet from Mach III to Music Server PC (RDC Control).
Removed Switching Supplies from everywhere (also from the PC).

For a general PC :
W10-10586.0 - May 2016 (2.05+)
*XXHighEnd PC -> I7 3930k with Hyperthreading On (12 cores)* @~500MHz, 16GB, Windows 10 Pro 64 bit build 10586.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/1/1/1 / Q1Factor = 1 / Dev.Buffer = 4096 / ClockRes = 1ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = 0.10  (max 60) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / All Services Off / Keep LAN - Not Persist / WallPaper On / OSD On / Running Time Off / Minimize OS / XTweaks : Balanced Load = *43* / Nervous Rate = 1 / Cool when Idle = 1 / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = *Optimal* / Time Stability = *Stable* / Custom Filter *Low* 705600 / -> USB3 *from MoBo* -> Clairixa USB 15cm -> Intona Isolator -> Clairixa USB 1m80 -> 24/768 Phasure NOS1a 75B (BNC Out) async USB DAC, Driver v1.0.4b (4ms) -> Blaxius BNC interlink *-> B'ASS Current Amplifier /w Level4 -> Blaxius Interlink* -> Orelo MKII Active Open Baffle Horn Speakers.
Removed Switching Supplies from everywhere.

Global Moderator
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1 RC2 | SMF © 2001-2005, Lewis Media Valid XHTML 1.0! Valid CSS!
Page created in 0.033 seconds with 19 queries.