XXHighEnd - The Ultra HighEnd Audio Player
April 22, 2019, 12:41:19 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: August 6, 2017 : Phasure Webshop open ! Go to the Shop
Search current board structure only !!  
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: Unattended - A single track in playlist stops playing seconds before end  (Read 521 times)
0 Members and 0 Guests are viewing this topic.
hudesigns
Audio Loudspeaker
*
Offline Offline

Posts: 85


View Profile Email
« on: January 15, 2019, 06:57:35 pm »

Hi Peter,
Long time no see! I have always noticed that if I put a single track in playlist in unattended mode. It does not play to the very end and stops at a few seconds before the end of song. I am using 2.10c. This issue might have been covered somewhere but I just can't find it.
Happy New Year!
Zheng
Logged

XXHighEnd PC -> I5-4460 (4 cores), @800Mhz, 24GB, Windows 10 Pro 64 bit build 10586.0 - Windows system, XXHE and XXHEdata on M.2 SSD on MoBo - Other temp folders on 2.5" internal SSD / XXHighEnd 2.10c, music on LAN / Engine#4 Adaptive Mode / Buffer = 1024 / Q1/-/3/4/5 = 11/-/1/1/1 / Q1Factor = 1 / ClockRes = 1ms / SFS = 5.19  (max 60) / Memory = Straight Contiguous / Include Garbage Collect / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 1-3 / UnAttended / Stop Desktop, Remaining, WASAPI and W10 services / Keep LAN - Not Persist / WallPaper Off / OSD Off / Running Time Off / Minimize OS / XTweaks : Balanced Load = 49 / Nervous Rate = 10 / Cool when Idle = 1 / Provide Stable Power = 1 / Utilize Cores always = 1 / Custom Filter second High 705600-> USB3 from MoBo -> Modified USB3 "Y" cable -> 32/384 async USB DAC iFi iDAC2 (in bit-perfect NOS mode) powered by battery--->

Setup 1: Fisher 80 mono preamplifiers -> 8417 (in triode mode) push pull mono amps -> Bi-wire with Naim NAC A5 speaker cable for woofer and military grade silver alloy cable to tweeter -> Linn Kan II speakers

Setup 2: Audio Research SP-3 preamplifier -> 45 (globe) single ended mono amps -> Altec 604e speakers
PeterSt
Administrator
High Grade Audiophile
*****
Offline Offline

Posts: 15412



View Profile Email
« Reply #1 on: January 15, 2019, 07:36:57 pm »

Hello Zheng - Happy New Year indeed !

I solved this a few days ago. All you now have to do is wait for the new version. Wink

Btw, I think it is not commonly known by others which recognize the issue as "the last track in the playlist", that this happens at a "Format Change". So in the middle of the playlist it can happen just the same, if only a next track is of another Sampling Rate than the current one. The current one now will cut (and for how much depends on the SFS).

Kind regards,
Peter
Logged

For the Stealth III LPS PC :
W10-14393.0 - Oct 31, 2018 (2.10)
XXHighEnd Mach III Stealth LPS PC -> Xeon Scalable 14/28 core with Hyperthreading On (set to 10/20 cores) @~660MHz, 48GB, Windows 10 Pro 64 bit build 14393.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 30/-/1/1/1/ Q1Factor = 10 / Dev.Buffer = 4096 / ClockRes = 15ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = 140.19  (max 140.19) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / Stop Desktop, Remaining, WASAPI and W10 services / Use Remote Desktop / Keep LAN - Not Persist / WallPaper On / OSD Off (!) / Running Time Off / Minimize OS / XTweaks : Balanced Load = 35 / Nervous Rate = 10 / Cool when Idle = n.a / Provide Stable Power = 0 / Utilize Cores always = 1 / Time Performance Index = Optimal / Time Stability = Stable / *Arc Prediction Filtering (16x)* / Always Clear Proxy before Playback = On -> USB3 from MoBo -> Lush^2*A:B-W-Y-R, B:B-W-R* USB 1m00 -> Phisolator 24/768 Phasure NOS1a/G3 75B (BNC Out) async USB DAC, Driver v1.0.4b (16ms) -> B'ASS Current Amplifier -> *Blaxius^2 A:B-R, B:B-R* Interlink -> Orelo MKII Active Open Baffle Horn Speakers.
Removed Switching Supplies from everywhere (also from the PC).

For a general PC :
W10-10586.0 - May 2016 (2.05+)
*XXHighEnd PC -> I7 3930k with Hyperthreading On (12 cores)* @~500MHz, 16GB, Windows 10 Pro 64 bit build 10586.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/1/1/1 / Q1Factor = 1 / Dev.Buffer = 4096 / ClockRes = 1ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = 0.10  (max 60) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / All Services Off / Keep LAN - Not Persist / WallPaper On / OSD On / Running Time Off / Minimize OS / XTweaks : Balanced Load = *43* / Nervous Rate = 1 / Cool when Idle = 1 / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = *Optimal* / Time Stability = *Stable* / Custom Filter *Low* 705600 / -> USB3 *from MoBo* -> Clairixa USB 15cm -> Intona Isolator -> Clairixa USB 1m80 -> 24/768 Phasure NOS1a 75B (BNC Out) async USB DAC, Driver v1.0.4b (4ms) -> Blaxius BNC interlink *-> B'ASS Current Amplifier /w Level4 -> Blaxius Interlink* -> Orelo MKII Active Open Baffle Horn Speakers.
Removed Switching Supplies from everywhere.

Global Moderator
hudesigns
Audio Loudspeaker
*
Offline Offline

Posts: 85


View Profile Email
« Reply #2 on: January 15, 2019, 11:57:25 pm »

Thanks much Peter! Looking forward to the next iteration. ZH
Logged

XXHighEnd PC -> I5-4460 (4 cores), @800Mhz, 24GB, Windows 10 Pro 64 bit build 10586.0 - Windows system, XXHE and XXHEdata on M.2 SSD on MoBo - Other temp folders on 2.5" internal SSD / XXHighEnd 2.10c, music on LAN / Engine#4 Adaptive Mode / Buffer = 1024 / Q1/-/3/4/5 = 11/-/1/1/1 / Q1Factor = 1 / ClockRes = 1ms / SFS = 5.19  (max 60) / Memory = Straight Contiguous / Include Garbage Collect / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 1-3 / UnAttended / Stop Desktop, Remaining, WASAPI and W10 services / Keep LAN - Not Persist / WallPaper Off / OSD Off / Running Time Off / Minimize OS / XTweaks : Balanced Load = 49 / Nervous Rate = 10 / Cool when Idle = 1 / Provide Stable Power = 1 / Utilize Cores always = 1 / Custom Filter second High 705600-> USB3 from MoBo -> Modified USB3 "Y" cable -> 32/384 async USB DAC iFi iDAC2 (in bit-perfect NOS mode) powered by battery--->

Setup 1: Fisher 80 mono preamplifiers -> 8417 (in triode mode) push pull mono amps -> Bi-wire with Naim NAC A5 speaker cable for woofer and military grade silver alloy cable to tweeter -> Linn Kan II speakers

Setup 2: Audio Research SP-3 preamplifier -> 45 (globe) single ended mono amps -> Altec 604e speakers
hudesigns
Audio Loudspeaker
*
Offline Offline

Posts: 85


View Profile Email
« Reply #3 on: January 18, 2019, 05:19:31 pm »

Hi Peter,
This is just FYI and might be helpful to others who have similar issues. It turns out that after I adjusted the Q1 and xQ1 values, the problem was basically solved. My old settings were Q1=30, xQ1=10 which I presume to be too high for my meager PC. The new settings are Q1=11, xQ1=1. So far it seems to be working fine. No more choke at the end of a track especially when it is the last or only track in playlist.
Best,
Zheng
Logged

XXHighEnd PC -> I5-4460 (4 cores), @800Mhz, 24GB, Windows 10 Pro 64 bit build 10586.0 - Windows system, XXHE and XXHEdata on M.2 SSD on MoBo - Other temp folders on 2.5" internal SSD / XXHighEnd 2.10c, music on LAN / Engine#4 Adaptive Mode / Buffer = 1024 / Q1/-/3/4/5 = 11/-/1/1/1 / Q1Factor = 1 / ClockRes = 1ms / SFS = 5.19  (max 60) / Memory = Straight Contiguous / Include Garbage Collect / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 1-3 / UnAttended / Stop Desktop, Remaining, WASAPI and W10 services / Keep LAN - Not Persist / WallPaper Off / OSD Off / Running Time Off / Minimize OS / XTweaks : Balanced Load = 49 / Nervous Rate = 10 / Cool when Idle = 1 / Provide Stable Power = 1 / Utilize Cores always = 1 / Custom Filter second High 705600-> USB3 from MoBo -> Modified USB3 "Y" cable -> 32/384 async USB DAC iFi iDAC2 (in bit-perfect NOS mode) powered by battery--->

Setup 1: Fisher 80 mono preamplifiers -> 8417 (in triode mode) push pull mono amps -> Bi-wire with Naim NAC A5 speaker cable for woofer and military grade silver alloy cable to tweeter -> Linn Kan II speakers

Setup 2: Audio Research SP-3 preamplifier -> 45 (globe) single ended mono amps -> Altec 604e speakers
PeterSt
Administrator
High Grade Audiophile
*****
Offline Offline

Posts: 15412



View Profile Email
« Reply #4 on: January 19, 2019, 05:57:53 am »


Dear Zheng,

Quote
My old settings were Q1=30, xQ1=10 which I presume to be too high for my meager PC.

I think I said SFS, but it is about what you mention (the net Q1 value). This is not related to a too meager PC etc., but it relates to how a larger buffer is dealt with internally. With the smaller settings it will still "cut" at the change of format or end of the playlist, but you may not be able to detect it any more. Say that a Q1 of 1x 11 implies a cut off of 100ms then 10x 11 implies 1000ms (one second). And so on. The speed of the PC does not matter to this.

Kind regards,
Peter
Logged

For the Stealth III LPS PC :
W10-14393.0 - Oct 31, 2018 (2.10)
XXHighEnd Mach III Stealth LPS PC -> Xeon Scalable 14/28 core with Hyperthreading On (set to 10/20 cores) @~660MHz, 48GB, Windows 10 Pro 64 bit build 14393.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 30/-/1/1/1/ Q1Factor = 10 / Dev.Buffer = 4096 / ClockRes = 15ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = 140.19  (max 140.19) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / Stop Desktop, Remaining, WASAPI and W10 services / Use Remote Desktop / Keep LAN - Not Persist / WallPaper On / OSD Off (!) / Running Time Off / Minimize OS / XTweaks : Balanced Load = 35 / Nervous Rate = 10 / Cool when Idle = n.a / Provide Stable Power = 0 / Utilize Cores always = 1 / Time Performance Index = Optimal / Time Stability = Stable / *Arc Prediction Filtering (16x)* / Always Clear Proxy before Playback = On -> USB3 from MoBo -> Lush^2*A:B-W-Y-R, B:B-W-R* USB 1m00 -> Phisolator 24/768 Phasure NOS1a/G3 75B (BNC Out) async USB DAC, Driver v1.0.4b (16ms) -> B'ASS Current Amplifier -> *Blaxius^2 A:B-R, B:B-R* Interlink -> Orelo MKII Active Open Baffle Horn Speakers.
Removed Switching Supplies from everywhere (also from the PC).

For a general PC :
W10-10586.0 - May 2016 (2.05+)
*XXHighEnd PC -> I7 3930k with Hyperthreading On (12 cores)* @~500MHz, 16GB, Windows 10 Pro 64 bit build 10586.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/1/1/1 / Q1Factor = 1 / Dev.Buffer = 4096 / ClockRes = 1ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = 0.10  (max 60) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / All Services Off / Keep LAN - Not Persist / WallPaper On / OSD On / Running Time Off / Minimize OS / XTweaks : Balanced Load = *43* / Nervous Rate = 1 / Cool when Idle = 1 / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = *Optimal* / Time Stability = *Stable* / Custom Filter *Low* 705600 / -> USB3 *from MoBo* -> Clairixa USB 15cm -> Intona Isolator -> Clairixa USB 1m80 -> 24/768 Phasure NOS1a 75B (BNC Out) async USB DAC, Driver v1.0.4b (4ms) -> Blaxius BNC interlink *-> B'ASS Current Amplifier /w Level4 -> Blaxius Interlink* -> Orelo MKII Active Open Baffle Horn Speakers.
Removed Switching Supplies from everywhere.

Global Moderator
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1 RC2 | SMF © 2001-2005, Lewis Media Valid XHTML 1.0! Valid CSS!
Page created in 0.1 seconds with 19 queries.