XXHighEnd - The Ultra HighEnd Audio Player
December 13, 2018, 10:40:35 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: August 6, 2017 : Phasure Webshop open ! Go to the Shop
Search current board structure only !!  
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: Alt-k does not persist unattended mode  (Read 3662 times)
0 Members and 0 Guests are viewing this topic.
charliemb
Audio Enthusiast
**
Offline Offline

Posts: 254


View Profile
« on: June 01, 2012, 12:46:41 am »

Is this a feature or a bug?

When xx returns from unattended mode, Alt-k reverts to unchecked / disabled.  However, I'd like this setting to persist.

To recreate my steps do the following: check / enable stop play at end of track, either by using the mouse or by entering Alt-k, before clicking play from the main interface while in attended mode;  then hit play.  After a few seconds of play, click Alt-s, or Alt-x.   (I believe you can also wait for the music to stop playing, 99% sure.)   When xx returns, notice the state of the stop playback button.   Is it enabled or disabled?

version is 0.9z-6-1c

Logged

July 2015   *=appear to be critical:
XXHighEnd PC (i7 3930K) Hyperthreading On (12 cores) underclocked to *2.5GHz*, 16GB, Windows 7 Ultimate64 SP1 on 2.5” SATA2 spinning disk, XX on 2.5” OS disk, music on 3.5” SATA3 7200 RPM.  Motherboard BIOS settings: BCLK = 100 MHz / Intel Speed Step = OFF / Max Clock Ratio = 25 / Allow OS to change ratio = OFF. 
XXHighEnd 2.01 Adaptive / Q1/3/4/5 = 6/1/1/1 / Q1x = 1 / Dev.Buffer = 4096 / ClockRes = 1ms / Straight Contiguous / SFS = *60* (max 150) / Playerprio = Low (or below normal) / ThreadPrio = High / Core3-5 / *No Playback Drive* / *No RAMDISK* (the built-in one, have not tried IMdisk) / UnAttended / most services Off, WASAPI on  / Minimize OS / XTweaks set to v2.01 Defaults / *8x 384 Custom Filters* (High 23380 Hz)
DAC: 384KHz Wyred 4 Sound DAC2 DSDse set to default PCM Rolloff=FAST (the SLOW setting does not sufficiently filter out the noise shaping of the DAC), and no preamp
PeterSt
Administrator
High Grade Audiophile
*****
Offline Offline

Posts: 15320



View Profile Email
« Reply #1 on: June 01, 2012, 06:35:38 am »

Hi Charlie,

I'm afraid this is a feature. It is really meant to happen "one time". I use it for :

1. Try one track of an unknown album in Unattended, so the whole Playlist doesn't need preparation of all the tracks (only the one selected is prepared now);

2. During playback of Unattended get fed up with the further play of an album (Playlist) but let all end nicely at the end of the currently playing track.

It's purpose is #2. And you'd want that to happen one time only. When it would work like you suggest/like, always #1 applies right after #2 (which latter, remember, is the purpose).

Regards,
Peter
Logged

For the Stealth III LPS PC :
W10-14393.0 - Oct 31, 2018 (2.10)
XXHighEnd Mach III Stealth LPS PC -> Xeon Scalable 14/28 core with Hyperthreading On (set to 10/20 cores) @~660MHz, 48GB, Windows 10 Pro 64 bit build 14393.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 30/-/1/1/1/ Q1Factor = 10 / Dev.Buffer = 4096 / ClockRes = 15ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = 140.19  (max 140.19) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / Stop Desktop, Remaining, WASAPI and W10 services / Use Remote Desktop / Keep LAN - Not Persist / WallPaper On / OSD Off (!) / Running Time Off / Minimize OS / XTweaks : Balanced Load = 35 / Nervous Rate = 10 / Cool when Idle = n.a / Provide Stable Power = 0 / Utilize Cores always = 1 / Time Performance Index = Optimal / Time Stability = Stable / *Arc Prediction Filtering (16x)* / Always Clear Proxy before Playback = On -> USB3 from MoBo -> Lush^2*A:B-W-Y-R, B:B-W-R* USB 1m00 -> Phisolator 24/768 Phasure NOS1a/G3 75B (BNC Out) async USB DAC, Driver v1.0.4b (16ms) -> B'ASS Current Amplifier -> *Blaxius^2 A:B-R, B:B-R* Interlink -> Orelo MKII Active Open Baffle Horn Speakers.
Removed Switching Supplies from everywhere (also from the PC).

For a general PC :
W10-10586.0 - May 2016 (2.05+)
*XXHighEnd PC -> I7 3930k with Hyperthreading On (12 cores)* @~500MHz, 16GB, Windows 10 Pro 64 bit build 10586.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/1/1/1 / Q1Factor = 1 / Dev.Buffer = 4096 / ClockRes = 1ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = 0.10  (max 60) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / All Services Off / Keep LAN - Not Persist / WallPaper On / OSD On / Running Time Off / Minimize OS / XTweaks : Balanced Load = *43* / Nervous Rate = 1 / Cool when Idle = 1 / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = *Optimal* / Time Stability = *Stable* / Custom Filter *Low* 705600 / -> USB3 *from MoBo* -> Clairixa USB 15cm -> Intona Isolator -> Clairixa USB 1m80 -> 24/768 Phasure NOS1a 75B (BNC Out) async USB DAC, Driver v1.0.4b (4ms) -> Blaxius BNC interlink *-> B'ASS Current Amplifier /w Level4 -> Blaxius Interlink* -> Orelo MKII Active Open Baffle Horn Speakers.
Removed Switching Supplies from everywhere.

Global Moderator
charliemb
Audio Enthusiast
**
Offline Offline

Posts: 254


View Profile
« Reply #2 on: June 01, 2012, 06:25:03 pm »

That makes sense and I am happy to readjust (or you could add a persist button eventually...  Happy kind of like a Caps Lock )   JRiver persists BTW.

Anyway, Relating to #2 above, I am affraid that tonight I may have to report a bug.  I will reconfirm that #2 does not work that way from within unattended mode.   In other words, I'm 92.5% sure that it just keeps on playing through past the end of the current song if I hit Alt-k while in unattended.

At the very least, it malfunctioned the first time I tried it and I just figured that worked that way and that Alt-k had to be enabled before hitting play.
Logged

July 2015   *=appear to be critical:
XXHighEnd PC (i7 3930K) Hyperthreading On (12 cores) underclocked to *2.5GHz*, 16GB, Windows 7 Ultimate64 SP1 on 2.5” SATA2 spinning disk, XX on 2.5” OS disk, music on 3.5” SATA3 7200 RPM.  Motherboard BIOS settings: BCLK = 100 MHz / Intel Speed Step = OFF / Max Clock Ratio = 25 / Allow OS to change ratio = OFF. 
XXHighEnd 2.01 Adaptive / Q1/3/4/5 = 6/1/1/1 / Q1x = 1 / Dev.Buffer = 4096 / ClockRes = 1ms / Straight Contiguous / SFS = *60* (max 150) / Playerprio = Low (or below normal) / ThreadPrio = High / Core3-5 / *No Playback Drive* / *No RAMDISK* (the built-in one, have not tried IMdisk) / UnAttended / most services Off, WASAPI on  / Minimize OS / XTweaks set to v2.01 Defaults / *8x 384 Custom Filters* (High 23380 Hz)
DAC: 384KHz Wyred 4 Sound DAC2 DSDse set to default PCM Rolloff=FAST (the SLOW setting does not sufficiently filter out the noise shaping of the DAC), and no preamp
PeterSt
Administrator
High Grade Audiophile
*****
Offline Offline

Posts: 15320



View Profile Email
« Reply #3 on: June 01, 2012, 06:35:23 pm »

You can be very well right on that Charlie. I was a bit reluctant to propose my #2, because I had the idea (from months ago) that it didn't work anymore. But it should !

I will look into it of course.
Logged

For the Stealth III LPS PC :
W10-14393.0 - Oct 31, 2018 (2.10)
XXHighEnd Mach III Stealth LPS PC -> Xeon Scalable 14/28 core with Hyperthreading On (set to 10/20 cores) @~660MHz, 48GB, Windows 10 Pro 64 bit build 14393.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 30/-/1/1/1/ Q1Factor = 10 / Dev.Buffer = 4096 / ClockRes = 15ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = 140.19  (max 140.19) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / Stop Desktop, Remaining, WASAPI and W10 services / Use Remote Desktop / Keep LAN - Not Persist / WallPaper On / OSD Off (!) / Running Time Off / Minimize OS / XTweaks : Balanced Load = 35 / Nervous Rate = 10 / Cool when Idle = n.a / Provide Stable Power = 0 / Utilize Cores always = 1 / Time Performance Index = Optimal / Time Stability = Stable / *Arc Prediction Filtering (16x)* / Always Clear Proxy before Playback = On -> USB3 from MoBo -> Lush^2*A:B-W-Y-R, B:B-W-R* USB 1m00 -> Phisolator 24/768 Phasure NOS1a/G3 75B (BNC Out) async USB DAC, Driver v1.0.4b (16ms) -> B'ASS Current Amplifier -> *Blaxius^2 A:B-R, B:B-R* Interlink -> Orelo MKII Active Open Baffle Horn Speakers.
Removed Switching Supplies from everywhere (also from the PC).

For a general PC :
W10-10586.0 - May 2016 (2.05+)
*XXHighEnd PC -> I7 3930k with Hyperthreading On (12 cores)* @~500MHz, 16GB, Windows 10 Pro 64 bit build 10586.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/1/1/1 / Q1Factor = 1 / Dev.Buffer = 4096 / ClockRes = 1ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = 0.10  (max 60) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / All Services Off / Keep LAN - Not Persist / WallPaper On / OSD On / Running Time Off / Minimize OS / XTweaks : Balanced Load = *43* / Nervous Rate = 1 / Cool when Idle = 1 / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = *Optimal* / Time Stability = *Stable* / Custom Filter *Low* 705600 / -> USB3 *from MoBo* -> Clairixa USB 15cm -> Intona Isolator -> Clairixa USB 1m80 -> 24/768 Phasure NOS1a 75B (BNC Out) async USB DAC, Driver v1.0.4b (4ms) -> Blaxius BNC interlink *-> B'ASS Current Amplifier /w Level4 -> Blaxius Interlink* -> Orelo MKII Active Open Baffle Horn Speakers.
Removed Switching Supplies from everywhere.

Global Moderator
charliemb
Audio Enthusiast
**
Offline Offline

Posts: 254


View Profile
« Reply #4 on: June 02, 2012, 12:23:02 am »

For sure it does NOT work.  I just tried twice (with reboot in between).

(Although both times xxHE came up with error warnings, which is a new problem I was not enountering even yesterday)
Logged

July 2015   *=appear to be critical:
XXHighEnd PC (i7 3930K) Hyperthreading On (12 cores) underclocked to *2.5GHz*, 16GB, Windows 7 Ultimate64 SP1 on 2.5” SATA2 spinning disk, XX on 2.5” OS disk, music on 3.5” SATA3 7200 RPM.  Motherboard BIOS settings: BCLK = 100 MHz / Intel Speed Step = OFF / Max Clock Ratio = 25 / Allow OS to change ratio = OFF. 
XXHighEnd 2.01 Adaptive / Q1/3/4/5 = 6/1/1/1 / Q1x = 1 / Dev.Buffer = 4096 / ClockRes = 1ms / Straight Contiguous / SFS = *60* (max 150) / Playerprio = Low (or below normal) / ThreadPrio = High / Core3-5 / *No Playback Drive* / *No RAMDISK* (the built-in one, have not tried IMdisk) / UnAttended / most services Off, WASAPI on  / Minimize OS / XTweaks set to v2.01 Defaults / *8x 384 Custom Filters* (High 23380 Hz)
DAC: 384KHz Wyred 4 Sound DAC2 DSDse set to default PCM Rolloff=FAST (the SLOW setting does not sufficiently filter out the noise shaping of the DAC), and no preamp
PeterSt
Administrator
High Grade Audiophile
*****
Offline Offline

Posts: 15320



View Profile Email
« Reply #5 on: June 02, 2012, 06:20:56 am »

I know, I tried it myself yesterday;
With my "but it should" I meant that it is supposed to work. So, a bug.
Logged

For the Stealth III LPS PC :
W10-14393.0 - Oct 31, 2018 (2.10)
XXHighEnd Mach III Stealth LPS PC -> Xeon Scalable 14/28 core with Hyperthreading On (set to 10/20 cores) @~660MHz, 48GB, Windows 10 Pro 64 bit build 14393.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 30/-/1/1/1/ Q1Factor = 10 / Dev.Buffer = 4096 / ClockRes = 15ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = 140.19  (max 140.19) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / Stop Desktop, Remaining, WASAPI and W10 services / Use Remote Desktop / Keep LAN - Not Persist / WallPaper On / OSD Off (!) / Running Time Off / Minimize OS / XTweaks : Balanced Load = 35 / Nervous Rate = 10 / Cool when Idle = n.a / Provide Stable Power = 0 / Utilize Cores always = 1 / Time Performance Index = Optimal / Time Stability = Stable / *Arc Prediction Filtering (16x)* / Always Clear Proxy before Playback = On -> USB3 from MoBo -> Lush^2*A:B-W-Y-R, B:B-W-R* USB 1m00 -> Phisolator 24/768 Phasure NOS1a/G3 75B (BNC Out) async USB DAC, Driver v1.0.4b (16ms) -> B'ASS Current Amplifier -> *Blaxius^2 A:B-R, B:B-R* Interlink -> Orelo MKII Active Open Baffle Horn Speakers.
Removed Switching Supplies from everywhere (also from the PC).

For a general PC :
W10-10586.0 - May 2016 (2.05+)
*XXHighEnd PC -> I7 3930k with Hyperthreading On (12 cores)* @~500MHz, 16GB, Windows 10 Pro 64 bit build 10586.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/1/1/1 / Q1Factor = 1 / Dev.Buffer = 4096 / ClockRes = 1ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = 0.10  (max 60) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / All Services Off / Keep LAN - Not Persist / WallPaper On / OSD On / Running Time Off / Minimize OS / XTweaks : Balanced Load = *43* / Nervous Rate = 1 / Cool when Idle = 1 / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = *Optimal* / Time Stability = *Stable* / Custom Filter *Low* 705600 / -> USB3 *from MoBo* -> Clairixa USB 15cm -> Intona Isolator -> Clairixa USB 1m80 -> 24/768 Phasure NOS1a 75B (BNC Out) async USB DAC, Driver v1.0.4b (4ms) -> Blaxius BNC interlink *-> B'ASS Current Amplifier /w Level4 -> Blaxius Interlink* -> Orelo MKII Active Open Baffle Horn Speakers.
Removed Switching Supplies from everywhere.

Global Moderator
PeterSt
Administrator
High Grade Audiophile
*****
Offline Offline

Posts: 15320



View Profile Email
« Reply #6 on: July 02, 2012, 12:31:55 pm »

Solved for 0.9z-7.
Logged

For the Stealth III LPS PC :
W10-14393.0 - Oct 31, 2018 (2.10)
XXHighEnd Mach III Stealth LPS PC -> Xeon Scalable 14/28 core with Hyperthreading On (set to 10/20 cores) @~660MHz, 48GB, Windows 10 Pro 64 bit build 14393.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 30/-/1/1/1/ Q1Factor = 10 / Dev.Buffer = 4096 / ClockRes = 15ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = 140.19  (max 140.19) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / Stop Desktop, Remaining, WASAPI and W10 services / Use Remote Desktop / Keep LAN - Not Persist / WallPaper On / OSD Off (!) / Running Time Off / Minimize OS / XTweaks : Balanced Load = 35 / Nervous Rate = 10 / Cool when Idle = n.a / Provide Stable Power = 0 / Utilize Cores always = 1 / Time Performance Index = Optimal / Time Stability = Stable / *Arc Prediction Filtering (16x)* / Always Clear Proxy before Playback = On -> USB3 from MoBo -> Lush^2*A:B-W-Y-R, B:B-W-R* USB 1m00 -> Phisolator 24/768 Phasure NOS1a/G3 75B (BNC Out) async USB DAC, Driver v1.0.4b (16ms) -> B'ASS Current Amplifier -> *Blaxius^2 A:B-R, B:B-R* Interlink -> Orelo MKII Active Open Baffle Horn Speakers.
Removed Switching Supplies from everywhere (also from the PC).

For a general PC :
W10-10586.0 - May 2016 (2.05+)
*XXHighEnd PC -> I7 3930k with Hyperthreading On (12 cores)* @~500MHz, 16GB, Windows 10 Pro 64 bit build 10586.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/1/1/1 / Q1Factor = 1 / Dev.Buffer = 4096 / ClockRes = 1ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = 0.10  (max 60) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / All Services Off / Keep LAN - Not Persist / WallPaper On / OSD On / Running Time Off / Minimize OS / XTweaks : Balanced Load = *43* / Nervous Rate = 1 / Cool when Idle = 1 / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = *Optimal* / Time Stability = *Stable* / Custom Filter *Low* 705600 / -> USB3 *from MoBo* -> Clairixa USB 15cm -> Intona Isolator -> Clairixa USB 1m80 -> 24/768 Phasure NOS1a 75B (BNC Out) async USB DAC, Driver v1.0.4b (4ms) -> Blaxius BNC interlink *-> B'ASS Current Amplifier /w Level4 -> Blaxius Interlink* -> Orelo MKII Active Open Baffle Horn Speakers.
Removed Switching Supplies from everywhere.

Global Moderator
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1 RC2 | SMF © 2001-2005, Lewis Media Valid XHTML 1.0! Valid CSS!
Page created in 0.074 seconds with 19 queries.