XXHighEnd - The Ultra HighEnd Audio Player
May 22, 2024, 01:09:40 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: August 6, 2017 : Phasure Webshop open ! Go to the Shop
Search current board structure only !!  
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: Uncommented test code?  (Read 5068 times)
0 Members and 0 Guests are viewing this topic.
charliemb
Audio Enthusiast
**
Offline Offline

Posts: 278


View Profile
« on: April 14, 2014, 04:47:45 pm »

From another thread:
Of course, that post in your topic about 48->176.4 could have been a hint, but still not because you found a dozen of these kind of bugs before. Still, when I started this little project I was thinking of you ...

Thank you, thank you.

And this reminds me that I've forgotten to report another situation where I think some test code was not commented out prior to compiling.  Now mind you, I'm running 0.9z-9b (otherwise prior to 1.186a).  And I think it is related to the above.

If I am playing around with 1x 2x 4x upsampling and choosing AI vs. AP vs. nothing (repeating bits) filter, I usually need to change two of these settings for each A/B comparison.  All of this works normally under attended.   But under unattended here is what happens:

Say I want to compare AI at 2x against AP at 4x.  I start with AI at 2x.  Then:

1. play a track unattended.   Listen for a while
2. hit alt-x
3. once xxHE comes up I click on stop or hit alt-s
4. I change filter from current setting to AP.  At this point I also want to change the upsampling ratio from 2x to 4x,  BUT I CAN'T!!!
5. Instead, xxHE immediately goes into play mode as if I had hit play.  I can't select 4x

And so i now am forced to hit alt-x again, wait , wait, wait, and then hit stop and finally change the ratio to 4x.

The only way I can work around this is to click [c] between changes.

So  I believe that this is test code left over for you to be able to quickly switch between AI and AP at 4x.  ...and should be commented out before final compile for the version that goes out non-beta.
Logged

July 2019:
XXHighEnd PC (i7 3930K) Hyperthreading On (12 cores) clocked to 3.6GHz (100%), 16GB, Windows 7 Ultimate64 SP1 on 2.5” SATA2 SSD disk for OS and XX, music on 3.5” SATA3 7200 RPM.  Motherboard BIOS settings: BCLK = 100 MHz / Intel Speed Step = OFF / Max Clock Ratio = 36 / Allow OS to change ratio = *OFF*. 
XXHighEnd 2.10 Adaptive / Q1/3/4/5 = 2/0/0/1 / Q1x = 1 / Dev.Buffer = 4096 / ClockRes = 1ms / Straight Contiguous / SFS = 30 (max 150) / Playerprio = Low (or below normal) / ThreadPrio = High / Core3-5 / No Playback Drive / No RAMDISK / UnAttended / most services Off, WASAPI on  / Minimize OS / XTweaks set to v2.01 Defaults / 16x 768K Custom Filters (High) or ArcPredict
DAC: Holo Audio Spring 2 KTE NOS DAC, and no preamp (also ISO REGEN powered by battery)
PeterSt
Administrator
High Grade Audiophile
*****
Offline Offline

Posts: 16837



View Profile Email
« Reply #1 on: April 14, 2014, 04:58:17 pm »

Hahaha, yes. Since yesterday that's in my ToDo.

So when the AI button is clicked it actually sees this as a real time change and it start to convert and play.

You report the other way around I think (change to AP) but it will be the same thing.

Will be solved - and thanks ...
Peter
Logged

For the Stealth III LPS PC :
W10-14393.0 - July 17, 2021 (2.11)
XXHighEnd Mach III Stealth LPS PC -> Xeon Scalable 14/28 core with Hyperthreading On (set to 14/28 cores in BIOS and set to 10/20 cores via Boot Menu) @~660MHz, 48GB, Windows 10 Pro 64 bit build 14393.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/0/0/*1*/ Q1Factor = *4* / Dev.Buffer = 4096 / ClockRes = *10ms* / Memory = Straight Contiguous / Include Garbage Collect / SFS = *10.13*  (max 10.13) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / Stop Desktop, Remaining, WASAPI and W10 services / Use Remote Desktop / Keep LAN - Not Persist / WallPaper On / OSD Off (!) / Running Time Off / Minimize OS / XTweaks : Balanced Load = *62* / Nervous Rate = *1* / Cool when Idle = n.a / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = Optimal / Time Stability = Stable / Custom Filtering *Low* (16x) / Always Clear Proxy before Playback = On -> USB3 from MoBo -> Lush^3
A: W-Y-R-G, B: *W-G* USB 1m00 -> Phisolator 24/768 Phasure NOS1a/G3 75B (BNC Out) async USB DAC, Driver v1.0.4b (16ms) -> B'ASS Current Amplifier -> Blaxius*^2.5* A:B-G, B:B-G Interlink -> Orelo MKII Active Open Baffle Horn Speakers. ET^2 Ethernet from Mach III to Music Server PC (RDC Control).
Removed Switching Supplies from everywhere (also from the PC).

For a general PC :
W10-10586.0 - May 2016 (2.05+)
*XXHighEnd PC -> I7 3930k with Hyperthreading On (12 cores)* @~500MHz, 16GB, Windows 10 Pro 64 bit build 10586.0 from RAM, music on LAN / Engine#4 Adaptive Mode / Q1/-/3/4/5 = 14/-/1/1/1 / Q1Factor = 1 / Dev.Buffer = 4096 / ClockRes = 1ms / Memory = Straight Contiguous / Include Garbage Collect / SFS = 0.10  (max 60) / not Invert / Phase Alignment Off / Playerprio = Low / ThreadPrio = Realtime / Scheme = Core 3-5 / Not Switch Processors during Playback = Off/ Playback Drive none (see OS from RAM) / UnAttended (Just Start) / Always Copy to XX Drive (see OS from RAM) / All Services Off / Keep LAN - Not Persist / WallPaper On / OSD On / Running Time Off / Minimize OS / XTweaks : Balanced Load = *43* / Nervous Rate = 1 / Cool when Idle = 1 / Provide Stable Power = 1 / Utilize Cores always = 1 / Time Performance Index = *Optimal* / Time Stability = *Stable* / Custom Filter *Low* 705600 / -> USB3 *from MoBo* -> Clairixa USB 15cm -> Intona Isolator -> Clairixa USB 1m80 -> 24/768 Phasure NOS1a 75B (BNC Out) async USB DAC, Driver v1.0.4b (4ms) -> Blaxius BNC interlink *-> B'ASS Current Amplifier /w Level4 -> Blaxius Interlink* -> Orelo MKII Active Open Baffle Horn Speakers.
Removed Switching Supplies from everywhere.

Global Moderator
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1 RC2 | SMF © 2001-2005, Lewis Media Valid XHTML 1.0! Valid CSS!
Page created in 0.033 seconds with 19 queries.